aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTony Battersby <tonyb@cybernetics.com>2021-08-09 10:32:52 -0400
committerArmin Kuster <akuster808@gmail.com>2021-08-14 07:14:14 -0700
commit2e794f33a43d71bb98619f3d7efaa460ebd7e12f (patch)
treeed1ea69e2ad2fa1422adcfacc43f2e86aa2bd64f
parentbca3bbbf203086794e5b56a71c04a7bbc59f9bea (diff)
downloadmeta-openembedded-contrib-2e794f33a43d71bb98619f3d7efaa460ebd7e12f.tar.gz
ldns: fix QA Issue after LDFLAGS change
Adding -f*-prefix-map to LDFLAGS caused the following issue: QA Issue: ldns.pc failed sanity test (tmpdir) Fix by filtering out -f*-prefix-map from *.pc files. [YOCTO #14481] Signed-off-by: Tony Battersby <tonyb@cybernetics.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> (cherry picked from commit a4791bf2f37de55dd51971d34ac2252d3cf68f30) Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-devtools/ldns/ldns_1.7.1.bb7
1 files changed, 7 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/ldns/ldns_1.7.1.bb b/meta-oe/recipes-devtools/ldns/ldns_1.7.1.bb
index 2a52dd688a..2ce669154a 100644
--- a/meta-oe/recipes-devtools/ldns/ldns_1.7.1.bb
+++ b/meta-oe/recipes-devtools/ldns/ldns_1.7.1.bb
@@ -16,3 +16,10 @@ PACKAGECONFIG[drill] = "--with-drill,--without-drill"
EXTRA_OECONF = "--with-ssl=${STAGING_EXECPREFIXDIR} \
libtool=${TARGET_PREFIX}libtool"
+
+do_install:append() {
+ sed -e 's@[^ ]*-ffile-prefix-map=[^ "]*@@g' \
+ -e 's@[^ ]*-fdebug-prefix-map=[^ "]*@@g' \
+ -e 's@[^ ]*-fmacro-prefix-map=[^ "]*@@g' \
+ -i ${D}${libdir}/pkgconfig/*.pc
+}