aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2013-10-14 13:20:39 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-10-15 13:36:59 +0200
commit5cf24c4e8d2ae69f99f3a562708734167b3ceb2a (patch)
tree470ca00a91e82c04c10f6f3581b8cbc325c55164
parent28c546066e880524d9bb06def09078aa0c66c69f (diff)
downloadmeta-openembedded-contrib-5cf24c4e8d2ae69f99f3a562708734167b3ceb2a.tar.gz
python-pip: add 1.3.1
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-devtools/python/python-pip_1.3.1.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/python/python-pip_1.3.1.bb b/meta-oe/recipes-devtools/python/python-pip_1.3.1.bb
new file mode 100644
index 0000000000..435b29abbe
--- /dev/null
+++ b/meta-oe/recipes-devtools/python/python-pip_1.3.1.bb
@@ -0,0 +1,14 @@
+SUMMARY = "PIP is a tool for installing and managing Python packages."
+LICENSE = "MIT & GPL"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=cd00425a3465a0e4c81929b94241d3de"
+
+SRC_URI = "https://pypi.python.org/packages/source/p/pip/pip-${PV}.tar.gz"
+SRC_URI[md5sum] = "cbb27a191cebc58997c4da8513863153"
+SRC_URI[sha256sum] = "145eaa5d1ea1b062663da1f3a97780d7edea4c63c68a37c463b1deedf7bb4957"
+
+S = "${WORKDIR}/pip-${PV}"
+
+inherit setuptools
+
+# Since PIP is like CPAN for PERL we need to drag in all python modules to ensure everything works
+RDEPENDS_${PN} = "python-modules"