aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBen Shelton <ben.shelton@ni.com>2014-10-29 09:39:07 -0500
committerMartin Jansa <Martin.Jansa@gmail.com>2014-10-30 09:15:31 +0100
commit9efaed99125b1c4324663d9a1b2d3319c74e7278 (patch)
tree7f586c5c7000a344fdc45f7792275ad6516f7e89
parent3f7b49d039a169be88236e1b3e4bca25c6814284 (diff)
downloadmeta-openembedded-contrib-9efaed99125b1c4324663d9a1b2d3319c74e7278.tar.gz
openvpn: bypass check for /sbin/ip on the host
In the commit 'openvpn: use default iproute2 path', the configure flag to explicitly set the iproute2 path was removed, since busybox now provides the 'ip' applet at the default path. However, setting this flag is necessary to bypass the configure-time check for /sbin/ip on the host, which will otherwise fail if iproute2 is not installed on the host. Add back the flag (pointing to the correct path), and add a comment to describe why this is necessary. Signed-off-by: Ben Shelton <ben.shelton@ni.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-networking/recipes-support/openvpn/openvpn_2.3.4.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/openvpn/openvpn_2.3.4.bb b/meta-networking/recipes-support/openvpn/openvpn_2.3.4.bb
index 53801cbd7e..1fb722a44b 100644
--- a/meta-networking/recipes-support/openvpn/openvpn_2.3.4.bb
+++ b/meta-networking/recipes-support/openvpn/openvpn_2.3.4.bb
@@ -19,6 +19,9 @@ CFLAGS += "-fno-inline"
EXTRA_OECONF += "--enable-password-save --enable-iproute2"
EXTRA_OECONF += "${@base_contains('DISTRO_FEATURES', 'pam', '', '--disable-plugin-auth-pam', d)}"
+# Explicitly specify IPROUTE to bypass the configure-time check for /sbin/ip on the host.
+EXTRA_OECONF += "IPROUTE=/sbin/ip"
+
do_install_append() {
install -d ${D}/${sysconfdir}/init.d
install -d ${D}/${sysconfdir}/openvpn