aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAsh Charles <ash@gumstix.com>2014-05-26 08:52:51 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2014-06-10 12:16:23 +0200
commit799bff981545c48a33f84c93c3fc979708f39b49 (patch)
tree5ccd64307a5079fd0c69f03fe494fb5fe18611f7
parentcb41796a5e0573bf3676b5c54fcc12c6dd42f9fb (diff)
downloadmeta-openembedded-contrib-799bff981545c48a33f84c93c3fc979708f39b49.tar.gz
xfce4-dev-tools: Allow out of tree builds
The xdt-autogen target in the generated scripts/Makefile refers to a $(srcdir)/xdt-autogen.in file. For an out-of-tree build, this file is actually located in $(builddir)/xdt-autogen.in. See [1] Upstream-Status: Submitted [1] https://bugzilla.xfce.org/show_bug.cgi?id=10899 Signed-off-by: Ash Charles <ash@gumstix.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-xfce/recipes-xfce/xfce4-dev-tools/xfce4-dev-tools-4.11.0/xdt-autogen_dependency.patch13
-rw-r--r--meta-xfce/recipes-xfce/xfce4-dev-tools/xfce4-dev-tools_4.11.0.bb7
2 files changed, 18 insertions, 2 deletions
diff --git a/meta-xfce/recipes-xfce/xfce4-dev-tools/xfce4-dev-tools-4.11.0/xdt-autogen_dependency.patch b/meta-xfce/recipes-xfce/xfce4-dev-tools/xfce4-dev-tools-4.11.0/xdt-autogen_dependency.patch
new file mode 100644
index 0000000000..8e6bd35425
--- /dev/null
+++ b/meta-xfce/recipes-xfce/xfce4-dev-tools/xfce4-dev-tools-4.11.0/xdt-autogen_dependency.patch
@@ -0,0 +1,13 @@
+diff --git a/scripts/Makefile.am b/scripts/Makefile.am
+index f2f0600..8e677dc 100644
+--- a/scripts/Makefile.am
++++ b/scripts/Makefile.am
+@@ -10,7 +10,7 @@ bin_SCRIPTS = \
+ xdt-autogen \
+ xdt-commit
+
+-xdt-autogen: Makefile $(srcdir)/xdt-autogen.in
++xdt-autogen: Makefile xdt-autogen.in
+ rm -f xdt-autogen xdt-autogen.gen
+ sed -e 's,\@DATADIR\@,$(datadir),g' \
+ xdt-autogen.in \
diff --git a/meta-xfce/recipes-xfce/xfce4-dev-tools/xfce4-dev-tools_4.11.0.bb b/meta-xfce/recipes-xfce/xfce4-dev-tools/xfce4-dev-tools_4.11.0.bb
index 3312fbdfe3..ad3140e23c 100644
--- a/meta-xfce/recipes-xfce/xfce4-dev-tools/xfce4-dev-tools_4.11.0.bb
+++ b/meta-xfce/recipes-xfce/xfce4-dev-tools/xfce4-dev-tools_4.11.0.bb
@@ -9,13 +9,16 @@ inherit autotools
BBCLASSEXTEND = "native"
-SRC_URI = "http://archive.xfce.org/src/xfce/${BPN}/${@'${PV}'[0:4]}/${BPN}-${PV}.tar.bz2"
+SRC_URI = " \
+ http://archive.xfce.org/src/xfce/${BPN}/${@'${PV}'[0:4]}/${BPN}-${PV}.tar.bz2 \
+ file://xdt-autogen_dependency.patch \
+"
SRC_URI[md5sum] = "36112d0256092c30bd1b47105c547edf"
SRC_URI[sha256sum] = "2dccdd4935716a97db28464ba2403572ce03134fd7adf294e1a59eaf297e6555"
do_install_append() {
install -d ${D}${datadir}/aclocal
- install -m 644 m4macros/*.m4 ${D}${datadir}/aclocal/
+ install -m 644 ${S}/m4macros/*.m4 ${D}${datadir}/aclocal/
}
FILES_${PN} += "${datadir}/xfce4/dev-tools/m4macros/*.m4"