aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2014-06-02 12:19:49 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2014-06-10 12:30:09 +0200
commit440ccdf152c846572bf2b7636177181a9134a83f (patch)
tree3ea8e35d945e4e9df2f58fdb970836fce68f58d2
parent12e0e8fb34a2288830640305ed4a3ecce44f4918 (diff)
downloadmeta-openembedded-contrib-440ccdf152c846572bf2b7636177181a9134a83f.tar.gz
luajit: upgrade to 2.0.3, add native support
* http://luajit.org/changes.html says: This release has the new PS4 port and various important bugfixes over 2.0.2 - an update is recommended. * add native support (used by efl-native) * drop lua dependency, it doesn't need lua to be built before luajit * LIC_FILES_CHKSUM change is only from copyright year update < Copyright (C) 2005-2013 Mike Pall. All rights reserved. --- > Copyright (C) 2005-2014 Mike Pall. All rights reserved. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-devtools/luajit/luajit_2.0.3.bb (renamed from meta-oe/recipes-devtools/luajit/luajit_2.0.2.bb)17
1 files changed, 9 insertions, 8 deletions
diff --git a/meta-oe/recipes-devtools/luajit/luajit_2.0.2.bb b/meta-oe/recipes-devtools/luajit/luajit_2.0.3.bb
index b719b48e09..de3a40bbca 100644
--- a/meta-oe/recipes-devtools/luajit/luajit_2.0.2.bb
+++ b/meta-oe/recipes-devtools/luajit/luajit_2.0.3.bb
@@ -1,14 +1,13 @@
SUMMARY = "Just-In-Time Compiler for Lua"
LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=1793ef52a5d577794cd886a501a7f861"
+LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=97b6446bbf9d55616838f821585c5978"
HOMEPAGE = "http://luajit.org"
-DEPENDS += "lua5.1"
-SRC_URI = "http://luajit.org/download/LuaJIT-${PV}.tar.gz;name=tarball \
+SRC_URI = "http://luajit.org/download/LuaJIT-${PV}.tar.gz \
file://0001-Do-not-strip-automatically-this-leaves-the-stripping.patch \
- "
-SRC_URI[tarball.md5sum] = "112dfb82548b03377fbefbba2e0e3a5b"
-SRC_URI[tarball.sha256sum] = "c05202974a5890e777b181908ac237625b499aece026654d7cc33607e3f46c38"
+"
+SRC_URI[md5sum] = "f14e9104be513913810cd59c8c658dc0"
+SRC_URI[sha256sum] = "55be6cb2d101ed38acca32c5b1f99ae345904b365b642203194c585d27bebd79"
SRC_URI_append_fslmachine = " file://ppc-fixplt.patch "
@@ -16,6 +15,8 @@ S = "${WORKDIR}/LuaJIT-${PV}"
inherit pkgconfig binconfig
+BBCLASSEXTEND = "native"
+
do_configure_prepend() {
sed -i -e s:/usr/local:${prefix}:g ${S}/Makefile
sed -i -e s:/lib$:${base_libdir}:g ${S}/Makefile
@@ -35,9 +36,9 @@ do_compile () {
do_install () {
oe_runmake 'DESTDIR=${D}' install
- rmdir ${D}${datadir}/lua/5.1 \
+ rmdir ${D}${datadir}/lua/5.* \
${D}${datadir}/lua \
- ${D}${libdir}/lua/5.1 \
+ ${D}${libdir}/lua/5.* \
${D}${libdir}/lua
}