aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAmy Fong <amy.fong@windriver.com>2014-05-27 12:52:00 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2014-06-10 12:27:11 +0200
commit14af1771aad8e580837189155835f212a401e869 (patch)
tree64fff71b78d93428d643e083540e2200194b80a6
parent033964b269f448b2f330ef48e51dfa5611f1a650 (diff)
downloadmeta-openembedded-contrib-14af1771aad8e580837189155835f212a401e869.tar.gz
nodejs: Inherit pythonnative
nodejs should use python from python-native package. On some hosts, the default python is missing bz2 support. Signed-off-by: Amy Fong <amy.fong@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-devtools/nodejs/nodejs_0.8.18.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta-oe/recipes-devtools/nodejs/nodejs_0.8.18.bb b/meta-oe/recipes-devtools/nodejs/nodejs_0.8.18.bb
index 996d68ea6e..839bfa425f 100644
--- a/meta-oe/recipes-devtools/nodejs/nodejs_0.8.18.bb
+++ b/meta-oe/recipes-devtools/nodejs/nodejs_0.8.18.bb
@@ -5,6 +5,8 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=95a589a3257ab7dfe37d8a8379e3c72d"
DEPENDS = "openssl"
+inherit pythonnative
+
SRC_URI = "http://nodejs.org/dist/v${PV}/node-v${PV}.tar.gz \
file://0001-gcc-has-a-builtin-define-to-denote-hard-abi-when-in-.patch \
"
@@ -38,5 +40,5 @@ do_install () {
RDEPENDS_${PN} = "curl python-shell python-datetime python-subprocess python-crypt python-textutils python-netclient "
RDEPENDS_${PN}_class-native = ""
-FILES_${PN} += "${libdir}/node/wafadmin ${libdir}/node_modules ${libdir}/dtrace"
+FILES_${PN} += "${libdir}/node/wafadmin ${libdir}/node_modules ${libdir}/dtrace ${libdir}/*"
BBCLASSEXTEND = "native"