aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoy Li <rongqing.li@windriver.com>2014-08-06 14:44:27 +0800
committerCliff Brake <cbrake@bec-systems.com>2014-10-29 14:03:13 -0400
commit80764fddc4f6086a8941132ce36f23e79b2bf181 (patch)
tree3a11b4a90c2ab79489a04cfdb33854e702cc816b
parent518cd119a8724dbd485a5d5c5047de59e8fbd652 (diff)
downloadmeta-openembedded-contrib-80764fddc4f6086a8941132ce36f23e79b2bf181.tar.gz
ruby: fix a parallel building issue
Signed-off-by: Roy Li <rongqing.li@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Acked-by: Cliff Brake <cbrake@bec-systems.com>
-rw-r--r--meta-ruby/recipes-devtools/ruby/ruby/remove-the-dependency-on-dir.patch37
-rw-r--r--meta-ruby/recipes-devtools/ruby/ruby_1.9.3-p429.bb1
2 files changed, 38 insertions, 0 deletions
diff --git a/meta-ruby/recipes-devtools/ruby/ruby/remove-the-dependency-on-dir.patch b/meta-ruby/recipes-devtools/ruby/ruby/remove-the-dependency-on-dir.patch
new file mode 100644
index 0000000000..a4ac3eaccb
--- /dev/null
+++ b/meta-ruby/recipes-devtools/ruby/ruby/remove-the-dependency-on-dir.patch
@@ -0,0 +1,37 @@
+remove a duplicate dependency
+
+Upstream-status: Pending
+
+The install-rb-default dependency is as below:
+
+pre-install-rb-default:
+ mkdir -p $(RUBYLIBDIR)/bigdecimal
+
+install-rb-default: pre-install-rb-default $(RUBYLIBDIR)/bigdecimal
+
+In fact, dependency on $(RUBYLIBDIR)/bigdecimal is duplicate, and not rule
+for $(RUBYLIBDIR)/bigdecimal, once $(RUBYLIBDIR)/bigdecimal is checked before
+pre-install-rb-default, the below error will happen
+ *** No rule to make target `../../.ext/common/yaml', needed by `install-rb-default'. Stop
+
+Signed-off-by: Roy Li <rongqing.li@windriver.com>
+---
+ lib/mkmf.rb | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/lib/mkmf.rb b/lib/mkmf.rb
+index 1f5ed76..556684c 100644
+--- a/lib/mkmf.rb
++++ b/lib/mkmf.rb
+@@ -2054,7 +2054,7 @@ static: $(STATIC_LIB)#{$extout ? " install-rb" : ""}
+ end
+ for f in files
+ dest = "#{dir}/#{File.basename(f)}"
+- mfile.print("install-rb#{sfx}: #{dest} #{dir}\n")
++ mfile.print("install-rb#{sfx}: #{dest}\n")
+ mfile.print("#{dest}: #{f}\n")
+ mfile.print("\t$(Q) $(#{$extout ? 'COPY' : 'INSTALL_DATA'}) #{f} $(@D#{sep})\n")
+ if defined?($installed_list) and !$extout
+--
+1.7.10.4
+
diff --git a/meta-ruby/recipes-devtools/ruby/ruby_1.9.3-p429.bb b/meta-ruby/recipes-devtools/ruby/ruby_1.9.3-p429.bb
index 48a65a948b..7610602dc6 100644
--- a/meta-ruby/recipes-devtools/ruby/ruby_1.9.3-p429.bb
+++ b/meta-ruby/recipes-devtools/ruby/ruby_1.9.3-p429.bb
@@ -11,6 +11,7 @@ SRC_URI += "\
file://rubygems-1.8.11-binary-extensions.patch \
file://ruby-1.9.3-mkmf-verbose.patch \
file://ruby-1.9.3-install-cross.patch \
+ file://remove-the-dependency-on-dir.patch \
"
SRC_URI[md5sum] = "993c72f7f805a9eb453f90b0b7fe0d2b"
SRC_URI[sha256sum] = "d192d1afc46a7ef27b9d0a3c7a67b509048984db2c38907aa82641bdf980acf4"