aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Bunk <bunk@stusta.de>2019-05-12 00:09:27 +0300
committerKhem Raj <raj.khem@gmail.com>2019-05-11 23:35:30 -0700
commitd8f379083dc81ad61c49ace5d97752a321488bd6 (patch)
treed62208ddfb9c3c72d428ab3219133e8f298be695
parent847babb25e86a5618cf24ae61ed616303bfa9f19 (diff)
downloadmeta-openembedded-contrib-d8f379083dc81ad61c49ace5d97752a321488bd6.tar.gz
rdfind: Upgrade 1.3.4 -> 1.4.1
Remove patch for issue fixed upstream. The change in COPYING is due to updated FSF postal address. Signed-off-by: Adrian Bunk <bunk@stusta.de> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-support/rdfind/files/reproducible_build.patch46
-rw-r--r--meta-oe/recipes-support/rdfind/rdfind_1.3.4.bb17
-rw-r--r--meta-oe/recipes-support/rdfind/rdfind_1.4.1.bb16
3 files changed, 16 insertions, 63 deletions
diff --git a/meta-oe/recipes-support/rdfind/files/reproducible_build.patch b/meta-oe/recipes-support/rdfind/files/reproducible_build.patch
deleted file mode 100644
index 36728a7885..0000000000
--- a/meta-oe/recipes-support/rdfind/files/reproducible_build.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-Description: sort the filelist when it is complete to get reproducible behaviour
-Author: Reiner Herrmann <reiner@reiner-h.de>
-Bug-Debian: https://bugs.debian.org/795790
-
-Upstream-Status: Pending
-
-Signed-off-by: Andre McCurdy <armccurdy@gmail.com>
-
-Index: rdfind-1.3.4/Fileinfo.hh
-===================================================================
---- rdfind-1.3.4.orig/Fileinfo.hh
-+++ rdfind-1.3.4/Fileinfo.hh
-@@ -189,6 +189,10 @@ public:
- static bool compareondepth(const Fileinfo &a, const Fileinfo &b)
- {return (a.depth() < b.depth());}
-
-+ //returns true if a has lower filename than b)
-+ static bool compareonfilename(const Fileinfo &a, const Fileinfo &b)
-+ {return (a.name().compare(b.name()) < 0);}
-+
- //fills with bytes from the file. if lasttype is supplied,
- //it is used to see if the file needs to be read again - useful if
- //file is shorter than the length of the bytes field.
-@@ -235,6 +239,10 @@ public:
- static bool equaldepth(const Fileinfo &a, const Fileinfo &b)
- {return (a.depth()==b.depth());}
-
-+ //returns true if filenames are equal
-+ static bool equalfilename(const Fileinfo &a, const Fileinfo &b)
-+ {return (a.name()==b.name());}
-+
- //returns true if file is a regular file. call readfileinfo first!
- bool isRegularFile() {return m_info.is_file;}
-
-Index: rdfind-1.3.4/rdfind.cc
-===================================================================
---- rdfind-1.3.4.orig/rdfind.cc
-+++ rdfind-1.3.4/rdfind.cc
-@@ -349,6 +349,7 @@ int main(int narg, char *argv[])
- cout<<dryruntext<<"Now have "<<filelist1.size()<<" files in total."<<endl;
-
-
-+ gswd.sortlist(&Fileinfo::compareonfilename,&Fileinfo::equalfilename);
-
- //mark files with a unique number
- gswd.markitems();
diff --git a/meta-oe/recipes-support/rdfind/rdfind_1.3.4.bb b/meta-oe/recipes-support/rdfind/rdfind_1.3.4.bb
deleted file mode 100644
index 4d984ee05f..0000000000
--- a/meta-oe/recipes-support/rdfind/rdfind_1.3.4.bb
+++ /dev/null
@@ -1,17 +0,0 @@
-SUMMARY = "Rdfind is a program that finds duplicate files"
-HOMEPAGE = "https://rdfind.pauldreik.se/"
-LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://COPYING;md5=9ac2e7cff1ddaf48b6eab6028f23ef88"
-
-DEPENDS = "nettle"
-
-SRC_URI = "https://rdfind.pauldreik.se/${BP}.tar.gz \
- file://reproducible_build.patch \
-"
-
-SRC_URI[md5sum] = "97c0cb35933588413583c61d3b5f9adf"
-SRC_URI[sha256sum] = "a5f0b3f72093d927b93898c993479b35682cccb47f7393fb72bd4803212fcc7d"
-
-inherit autotools
-
-BBCLASSEXTEND = "native"
diff --git a/meta-oe/recipes-support/rdfind/rdfind_1.4.1.bb b/meta-oe/recipes-support/rdfind/rdfind_1.4.1.bb
new file mode 100644
index 0000000000..42f2064fd4
--- /dev/null
+++ b/meta-oe/recipes-support/rdfind/rdfind_1.4.1.bb
@@ -0,0 +1,16 @@
+SUMMARY = "Rdfind is a program that finds duplicate files"
+HOMEPAGE = "https://rdfind.pauldreik.se/"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=fa22e16ebbe6638b2bd253338fbded9f"
+
+DEPENDS = "nettle autoconf-archive"
+
+SRC_URI = "https://rdfind.pauldreik.se/${BP}.tar.gz \
+"
+
+SRC_URI[md5sum] = "180418c863b861d1df221bc486a07ce7"
+SRC_URI[sha256sum] = "30c613ec26eba48b188d2520cfbe64244f3b1a541e60909ce9ed2efb381f5e8c"
+
+inherit autotools
+
+BBCLASSEXTEND = "native"