aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Rafael Giani <crg7475@mailbox.org>2019-10-28 23:58:31 +0100
committerKhem Raj <raj.khem@gmail.com>2019-11-01 07:48:55 -0700
commitb29797ba4bd89208b572365ddf09b714af03ea46 (patch)
tree02f3c398115553a9ad6e8913ee1f020fc237146c
parent29d6510134637a314b46185b2f34c17b7038b2e5 (diff)
downloadmeta-openembedded-contrib-b29797ba4bd89208b572365ddf09b714af03ea46.tar.gz
opencv: Enable pkg-config .pc file generation
In OpenCV 4, .pc file generation is disabled by default. Yet, other software such as GStreamer and FFmpeg rely on the .pc files during build time configuration. Explicitely enable .pc file generation to make sure pkg-config can be used for getting information about OpenCV. Signed-off-by: Carlos Rafael Giani <crg7475@mailbox.org> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-support/opencv/opencv_4.1.0.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/opencv/opencv_4.1.0.bb b/meta-oe/recipes-support/opencv/opencv_4.1.0.bb
index 77b5dd60c4..5e89db0977 100644
--- a/meta-oe/recipes-support/opencv/opencv_4.1.0.bb
+++ b/meta-oe/recipes-support/opencv/opencv_4.1.0.bb
@@ -64,6 +64,7 @@ EXTRA_OECMAKE = "-DOPENCV_EXTRA_MODULES_PATH=${WORKDIR}/contrib/modules \
-DCMAKE_SKIP_RPATH=ON \
-DOPENCV_ICV_HASH=${IPP_MD5} \
-DIPPROOT=${WORKDIR}/ippicv_lnx \
+ -DOPENCV_GENERATE_PKGCONFIG=ON \
${@bb.utils.contains("TARGET_CC_ARCH", "-msse3", "-DENABLE_SSE=1 -DENABLE_SSE2=1 -DENABLE_SSE3=1 -DENABLE_SSSE3=1", "", d)} \
${@bb.utils.contains("TARGET_CC_ARCH", "-msse4.1", "-DENABLE_SSE=1 -DENABLE_SSE2=1 -DENABLE_SSE3=1 -DENABLE_SSSE3=1 -DENABLE_SSE41=1", "", d)} \
${@bb.utils.contains("TARGET_CC_ARCH", "-msse4.2", "-DENABLE_SSE=1 -DENABLE_SSE2=1 -DENABLE_SSE3=1 -DENABLE_SSSE3=1 -DENABLE_SSE41=1 -DENABLE_SSE42=1", "", d)} \