aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarek Vasut <marex@denx.de>2021-09-20 17:10:41 +0200
committerArmin Kuster <akuster808@gmail.com>2021-09-20 15:46:34 -0700
commit772157bb575837ac2c2635ad78947c411921938b (patch)
tree61628d7271a2f7df8f6f5864e7953495c5766c89
parentaa137e3344daea3643e446204bffc461c41f9708 (diff)
downloadmeta-openembedded-contrib-772157bb575837ac2c2635ad78947c411921938b.tar.gz
dstat: Add missing python-six runtime dependency
The tool depends on the six module, add it, otherwise the following traceback happens when running it on the target: Traceback (most recent call last): File "/usr/bin/dstat", line 32, in <module> import six ModuleNotFoundError: No module named 'six' Signed-off-by: Marek Vasut <marex@denx.de> Cc: Khem Raj <raj.khem@gmail.com> Cc: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> (cherry picked from commit 866e2e88911c0975403b6f2be2cd498b34c2b395) [minor fixup for Hardknott context] Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-support/dstat/dstat_0.7.4.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/dstat/dstat_0.7.4.bb b/meta-oe/recipes-support/dstat/dstat_0.7.4.bb
index 74af54ca53..a1076ccf94 100644
--- a/meta-oe/recipes-support/dstat/dstat_0.7.4.bb
+++ b/meta-oe/recipes-support/dstat/dstat_0.7.4.bb
@@ -21,4 +21,4 @@ do_install() {
oe_runmake 'DESTDIR=${D}' install
}
-RDEPENDS_${PN} += "python3-core python3-misc python3-resource python3-shell python3-unixadmin"
+RDEPENDS:${PN} += "python3-core python3-misc python3-resource python3-shell python3-six python3-unixadmin"