aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2012-04-08 11:12:56 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2012-04-08 14:33:41 +0200
commitd03ee17c2e40dcbbed9c6623f2e5169b4729f2e3 (patch)
treef92cac5f283ca9dd772fdcfc13cf8390ea218d2c
parent9fb576a0d53d4bd511eee64f44d4ed187acdd83c (diff)
downloadmeta-openembedded-contrib-d03ee17c2e40dcbbed9c6623f2e5169b4729f2e3.tar.gz
nodejs 0.6.x: update to 0.6.14
The LICENSE checksum changed due to date changes and clarification on licenses of included "libraries" like the markdown parser Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
-rw-r--r--meta-oe/recipes-devtools/nodejs/nodejs_0.6.14.bb (renamed from meta-oe/recipes-devtools/nodejs/nodejs_0.6.8.bb)22
1 files changed, 16 insertions, 6 deletions
diff --git a/meta-oe/recipes-devtools/nodejs/nodejs_0.6.8.bb b/meta-oe/recipes-devtools/nodejs/nodejs_0.6.14.bb
index bd404ae3ad..4f85bf3ffe 100644
--- a/meta-oe/recipes-devtools/nodejs/nodejs_0.6.8.bb
+++ b/meta-oe/recipes-devtools/nodejs/nodejs_0.6.14.bb
@@ -1,21 +1,26 @@
DESCRIPTION = "nodeJS Evented I/O for V8 JavaScript"
HOMEPAGE = "http://nodejs.org"
LICENSE = "MIT & BSD"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=672cc6c8dbb3e918277a61ea98f088f6"
-
-DEFAULT_PREFERENCE = "-1"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=d66c1f33ba9b89616e45f588e7606ee6"
DEPENDS = "openssl"
SRC_URI = "http://nodejs.org/dist/v${PV}/node-v${PV}.tar.gz"
-SRC_URI[md5sum] = "9fd7baa2d27b848c3134e6ae35bb87b2"
-SRC_URI[sha256sum] = "e6cbfc5ccdbe10128dbbd4dc7a88c154d80f8a39c3a8477092cf7d25eef78c9c"
+SRC_URI[md5sum] = "3033a866e230cca64e212ee8f2af27dd"
+SRC_URI[sha256sum] = "e41922308155c5197c2d048948ca9cd76ea5f9a51f977e1591bd93fe17d4cf1f"
S = "${WORKDIR}/node-v${PV}"
# v8 errors out if you have set CCACHE
CCACHE = ""
+do_configure_virtclass-native () {
+ sed -i -e s:\'/usr/lib:\'${STAGING_LIBDIR}:g wscript
+ sed -i -e s:\'/usr/local/lib:\'${STAGING_LIBDIR}:g wscript
+
+ ./configure --prefix=${prefix} --without-snapshot
+}
+
# Node is way too cool to use proper autotools, so we install two wrappers to forcefully inject proper arch cflags to workaround waf+scons
do_configure () {
echo '#!/bin/sh' > ${WORKDIR}/gcc
@@ -36,6 +41,10 @@ do_configure () {
./configure --prefix=${prefix} --without-snapshot
}
+do_compile_virtclass-native () {
+ make
+}
+
do_compile () {
export PATH=${WORKDIR}:${PATH}
export CC=gcc
@@ -48,6 +57,7 @@ do_install () {
}
RDEPENDS_${PN} = "curl python-shell python-datetime python-subprocess python-crypt python-textutils python-netclient "
+RDEPENDS_${PN}_virtclass-native = "curl-native python-native"
-FILES_${PN} += "${libdir}/node/wafadmin"
+FILES_${PN} += "${libdir}/node/wafadmin ${libdir}/node_modules"
BBCLASSEXTEND = "native"