aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2012-04-09 16:49:29 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2012-04-09 16:49:29 +0200
commitcd06a14023c12002a40e2ad585d45b521e624ad2 (patch)
tree8bb15acbea4a1d48505ba09de69bcba17d5384ba
parent06366a8833d2de85a0641134aa27a1c90577bfb5 (diff)
downloadmeta-openembedded-contrib-cd06a14023c12002a40e2ad585d45b521e624ad2.tar.gz
xbmc: fix .desktop for ARM
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
-rw-r--r--meta-oe/recipes-multimedia/xbmc/xbmc_git.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta-oe/recipes-multimedia/xbmc/xbmc_git.bb b/meta-oe/recipes-multimedia/xbmc/xbmc_git.bb
index 459b571ae6..0595c9bffe 100644
--- a/meta-oe/recipes-multimedia/xbmc/xbmc_git.bb
+++ b/meta-oe/recipes-multimedia/xbmc/xbmc_git.bb
@@ -58,6 +58,11 @@ do_compile_prepend() {
sed -i -e 's:I/usr/include:I${STAGING_INCDIR}:g' -e 's:-rpath \$(libdir)::g' ${S}/Makefile
}
+# on ARM architectures xbmc will use GLES which will make the regular wrapper fail, so start it directly
+do_install_append_arm() {
+ sed -i -e 's:Exec=xbmc:Exec=${libdir}/xbmc/xbmc.bin:g' ${D}${datadir}/applications/xbmc.desktop
+}
+
FILES_${PN} += "${datadir}/xsessions ${datadir}/icons"
FILES_${PN}-dbg += "${libdir}/xbmc/.debug ${libdir}/xbmc/*/.debug ${libdir}/xbmc/*/*/.debug ${libdir}/xbmc/*/*/*/.debug"