aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2012-04-11 18:18:06 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2012-04-11 18:20:46 +0200
commit67a2bd88ab32d2605e54d51e44006f77b98908b3 (patch)
tree86fb031c6ed6b4565de22f6b9e350f938954a3c3
parent21b04f590feb7dbd9e5932153b3ec46e38ecaecb (diff)
downloadmeta-openembedded-contrib-67a2bd88ab32d2605e54d51e44006f77b98908b3.tar.gz
xinput-calibrator 0.7.5: run xinput_calibrator_once.sh using XDG autostart mechanism
This runs when the session starts so after the DM. Not a great solution, but at least it will popup a calibration dialog automatically and restore calibration on subsequent sessions. Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
-rw-r--r--meta-oe/recipes-graphics/xinput-calibrator/xinput-calibrator/xinput-calibrator-autostart.desktop8
-rw-r--r--meta-oe/recipes-graphics/xinput-calibrator/xinput-calibrator_0.7.5.bb7
2 files changed, 14 insertions, 1 deletions
diff --git a/meta-oe/recipes-graphics/xinput-calibrator/xinput-calibrator/xinput-calibrator-autostart.desktop b/meta-oe/recipes-graphics/xinput-calibrator/xinput-calibrator/xinput-calibrator-autostart.desktop
new file mode 100644
index 0000000000..3f3d613278
--- /dev/null
+++ b/meta-oe/recipes-graphics/xinput-calibrator/xinput-calibrator/xinput-calibrator-autostart.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=Calibrate Touchscreen
+Exec=xinput_calibrator_once.sh
+Terminal=false
+Type=Application
+Icon=xinput_calibrator
+StartupNotify=true
+Categories=System;Settings;
diff --git a/meta-oe/recipes-graphics/xinput-calibrator/xinput-calibrator_0.7.5.bb b/meta-oe/recipes-graphics/xinput-calibrator/xinput-calibrator_0.7.5.bb
index d823e0e5a1..a50a0cfd73 100644
--- a/meta-oe/recipes-graphics/xinput-calibrator/xinput-calibrator_0.7.5.bb
+++ b/meta-oe/recipes-graphics/xinput-calibrator/xinput-calibrator_0.7.5.bb
@@ -4,13 +4,14 @@ LICENSE = "MIT-X"
LIC_FILES_CHKSUM = "file://src/calibrator.cpp;endline=22;md5=998e238a7638a7446eaeb02398f691fc"
DEPENDS = "virtual/libx11 libxi"
-PR = "r4"
+PR = "r5"
inherit autotools systemd
SRC_URI = "http://github.com/downloads/tias/xinput_calibrator/xinput_calibrator-${PV}.tar.gz \
file://0001-xinput_calibrator_pointercal.sh-specify-output-type-.patch \
file://xinput-calibrator.service \
+ file://xinput-calibrator-autostart.desktop \
"
SRC_URI[md5sum] = "20da0a2055a5a75962add8c6b44f60fa"
SRC_URI[sha256sum] = "baa4ddca49ec94c27ba4c715bfa26692fec1132103e927213c3169e475d3d971"
@@ -23,10 +24,14 @@ EXTRA_OECONF += "--with-gui=x11"
do_install_append() {
install -d ${D}${bindir}
install -m 0755 scripts/xinput_calibrator_pointercal.sh ${D}${bindir}/xinput_calibrator_once.sh
+
+ install -d ${D}${sysconfdir}/xdg/autostart
+ install -m 0644 ${WORKDIR}/xinput-calibrator-autostart.desktop ${D}${sysconfdir}/xdg/autostart
}
SYSTEMD_PACKAGES = "${PN}-systemd"
SYSTEMD_SERVICE = "${PN}.service"
+FILES_${PN} += "${sysconfdir}/xdg/autostart"
RDEPENDS_${PN} = "xinput"
RRECOMMENDS_${PN} = "pointercal-xinput"