aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2012-01-19 10:13:29 +0100
committerKoen Kooi <koen@dominion.thruhere.net>2012-01-20 12:22:19 +0100
commit3b80f538d9055f54b125d4f663ca147098674cce (patch)
tree2f18551d0b5caed6b05d6f718f74419a87089801
parent1ec5fa073fba7d2c63c15d4625fcd15362769fbf (diff)
downloadmeta-openembedded-contrib-3b80f538d9055f54b125d4f663ca147098674cce.tar.gz
python-imaging: fix #!/usr/local/bin/python problem
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
-rw-r--r--meta-oe/recipes-devtools/python/python-imaging_1.1.7.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/python/python-imaging_1.1.7.bb b/meta-oe/recipes-devtools/python/python-imaging_1.1.7.bb
index 851c53fe88..c8dd8147ce 100644
--- a/meta-oe/recipes-devtools/python/python-imaging_1.1.7.bb
+++ b/meta-oe/recipes-devtools/python/python-imaging_1.1.7.bb
@@ -1,6 +1,8 @@
DESCRIPTION = "Python Imaging Library"
SECTION = "devel/python"
+PR = "r1"
+
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://README;beginline=92;endline=117;md5=003338c482e1d2eb2e4d862897f3abbf"
@@ -31,6 +33,9 @@ do_install() {
install -m 0644 ${S}/README ${D}${datadir}/doc/${PN}/
install -m 0644 ${S}/Docs/* ${D}${datadir}/doc/${PN}/html/
+ # get rid of #!/usr/local/bin/python
+ sed -i -e 's:/usr/local/bin/:${bindir}/env :g' ${D}${bindir}/*
+
}
RDEPENDS_${PN} = "python-lang python-stringold"