aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorQi.Chen@windriver.com <Qi.Chen@windriver.com>2015-10-21 15:47:40 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2015-10-23 12:56:44 +0200
commitff477aa4e6199b3433ab315a5533ed89f09ad9c9 (patch)
treee5ca8d48e018a2aebe0130c8d7b7b746efa83f78
parent8e26d2cddf21dc7c187bd65ae90e7f4189e504bb (diff)
downloadmeta-openembedded-contrib-ff477aa4e6199b3433ab315a5533ed89f09ad9c9.tar.gz
rrdtool: fix multilib problem
When building rrdtool with multilib enabled, we would meet the following error. ERROR: QA Issue: rrdtool: Files/directories were installed but not shipped in any package: /usr/lib /usr/lib/python2.7 /usr/lib/python2.7/site-packages /usr/lib/python2.7/site-packages/rrdtool.so .... Fix this problem by using nonarch_libdir instead of libdir. Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-extended/rrdtool/rrdtool_1.5.4.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-oe/recipes-extended/rrdtool/rrdtool_1.5.4.bb b/meta-oe/recipes-extended/rrdtool/rrdtool_1.5.4.bb
index 9b54deb224..d9ac924697 100644
--- a/meta-oe/recipes-extended/rrdtool/rrdtool_1.5.4.bb
+++ b/meta-oe/recipes-extended/rrdtool/rrdtool_1.5.4.bb
@@ -117,8 +117,8 @@ RDEPENDS_${PN}-perl = "perl perl-module-lib perl-module-getopt-long perl-module-
DESCRIPTION_${PN}-python = \
"The ${PN}-python package includes RRDtool bindings for python."
-FILES_${PN}-python = "${libdir}/python${PYTHON_BASEVERSION}/site-packages/*"
+FILES_${PN}-python = "${nonarch_libdir}/python${PYTHON_BASEVERSION}/site-packages/*"
RDEPENDS_${PN}-python = "python"
FILES_${PN}-dbg += "${libdir}/perl/vendor_perl/*/auto/RRDs/.debug \
- ${libdir}/python${PYTHON_BASEVERSION}/site-packages/.debug"
+ ${nonarch_libdir}/python${PYTHON_BASEVERSION}/site-packages/.debug"