aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2015-10-30 12:42:18 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2015-11-06 17:49:37 +0100
commitf0226de0258ac485ba5b5152c7c01ac1d5bd66ba (patch)
treef8a2e81342fd5e189c33c3153cc4f30a4382e68c
parentabeb107be132687ff98f4de3e5e81fb6781a07d3 (diff)
downloadmeta-openembedded-contrib-f0226de0258ac485ba5b5152c7c01ac1d5bd66ba.tar.gz
fontforge: avoid cloning uthash during do_compile
Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
-rw-r--r--meta-oe/recipes-graphics/fontforge/fontforge_20150824.bb11
1 files changed, 9 insertions, 2 deletions
diff --git a/meta-oe/recipes-graphics/fontforge/fontforge_20150824.bb b/meta-oe/recipes-graphics/fontforge/fontforge_20150824.bb
index 5fab79cc2c..b50202d0a6 100644
--- a/meta-oe/recipes-graphics/fontforge/fontforge_20150824.bb
+++ b/meta-oe/recipes-graphics/fontforge/fontforge_20150824.bb
@@ -6,7 +6,7 @@ LIC_FILES_CHKSUM = " \
file://LICENSE;md5=3f922b42ed0033fa0fd4cd3268f6429c \
"
-DEPENDS = "glib-2.0 pango giflib tiff libxml2 jpeg python libtool"
+DEPENDS = "glib-2.0 pango giflib tiff libxml2 jpeg python libtool uthash"
DEPENDS_append_class-target = " libxi"
inherit autotools-bootstrap pkgconfig pythonnative distro_features_check
@@ -20,7 +20,14 @@ S = "${WORKDIR}/git"
EXTRA_OECONF_append_class-native = " with_x=no --disable-python-extension --disable-python-scripting"
-EXTRA_OEMAKE = "CFLAGS='${CFLAGS} -I${B}/uthash/src'"
+do_configure_prepend() {
+ # uthash sources are expected in uthash/src
+ currdir=`pwd`
+ cd ${S}
+ mkdir -p uthash/src
+ cp ${STAGING_INCDIR}/ut*.h uthash/src
+ cd $currdir
+}
PACKAGES =+ "${PN}-python-dbg ${PN}-python"