aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAmarnath Valluri <amarnath.valluri@intel.com>2015-11-06 15:27:37 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2015-11-11 10:46:54 +0100
commit9f3a2e92d385b2f0b0d8a40c2a6f1e5fb735a3e4 (patch)
tree6cbb349486ed47c5ef2d14cef3962398020cd3a1
parent08d51bca6adc8c5b2141916e783e3b7cdbd50ae3 (diff)
downloadmeta-openembedded-contrib-9f3a2e92d385b2f0b0d8a40c2a6f1e5fb735a3e4.tar.gz
nginx: Add support for altering build configuration
Passing EXTRA_OECONF to ./configure, this allows to alter build configure Signed-off-by: Amarnath Valluri <amarnath.valluri@intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-webserver/recipes-httpd/nginx/nginx_1.9.5.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/meta-webserver/recipes-httpd/nginx/nginx_1.9.5.bb b/meta-webserver/recipes-httpd/nginx/nginx_1.9.5.bb
index a251523bc8..1c9bff7fbc 100644
--- a/meta-webserver/recipes-httpd/nginx/nginx_1.9.5.bb
+++ b/meta-webserver/recipes-httpd/nginx/nginx_1.9.5.bb
@@ -27,6 +27,8 @@ inherit update-rc.d useradd
CFLAGS_append = " -fPIE -pie"
CXXFLAGS_append = " -fPIE -pie"
+EXTRA_OECONF = ""
+
do_configure () {
if [ "${SITEINFO_BITS}" = "64" ]; then
PTRSIZE=8
@@ -55,7 +57,8 @@ do_configure () {
--pid-path=/run/nginx/nginx.pid \
--prefix=${prefix} \
--with-http_ssl_module \
- --with-http_gzip_static_module
+ --with-http_gzip_static_module \
+ ${EXTRA_OECONF}
}
do_install () {