aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoe Slater <jslater@windriver.com>2014-09-12 16:04:18 -0700
committerJoe MacDonald <joe_macdonald@mentor.com>2014-09-23 21:59:42 -0400
commitf2715a565228a50cb9da1102d2758937addf21e3 (patch)
treeb92d1ab850accae72566cbe3d50b51df325e0969
parent28e26a9b0ad37d0c92ba42b2727215eef1edf5a2 (diff)
downloadmeta-openembedded-contrib-f2715a565228a50cb9da1102d2758937addf21e3.tar.gz
ptpd: update to version 2.3.1-rc2
Add a little processing to find correct directory for source upstream. Update LIC_FILES_CHKSUM since the latest package doesn't include a COPYRIGHT file anymore. Signed-off-by: Joe Slater <jslater@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
-rw-r--r--meta-networking/recipes-daemons/ptpd/ptpd_2.3.1-rc2.bb (renamed from meta-networking/recipes-daemons/ptpd/ptpd_2.3.0.bb)18
1 files changed, 14 insertions, 4 deletions
diff --git a/meta-networking/recipes-daemons/ptpd/ptpd_2.3.0.bb b/meta-networking/recipes-daemons/ptpd/ptpd_2.3.1-rc2.bb
index 54679dcf1d..db74e44631 100644
--- a/meta-networking/recipes-daemons/ptpd/ptpd_2.3.0.bb
+++ b/meta-networking/recipes-daemons/ptpd/ptpd_2.3.1-rc2.bb
@@ -6,17 +6,27 @@ time coordination of LAN connected computers."
HOMEPAGE = "http://sourceforge.net/projects/ptpd"
SECTION = "network"
LICENSE = "BSD"
-LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=4019cad2b3cd55f22ea819ffad6ccd41"
+LIC_FILES_CHKSUM = "file://README;md5=2452033fe374283f29579898663b1aa8"
DEPENDS = "libpcap"
inherit autotools
-SRC_URI = "http://downloads.sourceforge.net/project/ptpd/ptpd/${PV}/ptpd-${PV}.tar.gz"
+# return something like '1.2.3' or '1.2.3/rc1'
+#
+def get_sub(d):
+ parts = d.getVar('PV',True).split('-')
+ try:
+ return parts[0] + '/' + parts[1]
+ except:
+ return parts[0]
+
+SRC_URI = "http://downloads.sourceforge.net/project/ptpd/ptpd/${@get_sub(d)}/ptpd-${PV}.tar.gz"
+
+SRC_URI[md5sum] = "1ef2f1f2825080a865bbce0eb61246d4"
+SRC_URI[sha256sum] = "2802aab758649bb222859dfcb62a5d282709ccb4d3f1df3f26f739cc091d0c8d"
S = "${WORKDIR}/ptpd-${PV}"
-SRC_URI[md5sum] = "f5e931b4a229705ff0dbdfe22490566b"
-SRC_URI[sha256sum] = "1a4e90496f004bfd91657ccc49209101dc25b787e540648c07c0973469f1d8f7"
EXTRA_OEMAKE = ""