aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorWenzong Fan <wenzong.fan@windriver.com>2014-09-17 01:56:38 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2014-09-26 05:41:53 +0200
commite99ca149a158b046ee02fcaa589df9cdca164f01 (patch)
treea1a35ef00f0043c730a4adcfea1b97f7e36c7f9b
parent711f3b8da8547b510235bfddfc6d4880017b7a37 (diff)
downloadmeta-openembedded-contrib-e99ca149a158b046ee02fcaa589df9cdca164f01.tar.gz
talloc: fix swig dependencies
* depens on swig-native to make sure that the talloc.i always be installed; * remove relative path that from `swig -swiglib`: ${D}/usr/bin/../share -> ${D}/usr/share This prevents 'install' from creraing empty dir: ${D}${bindir}; * fix the path to talloc.i for separate build. Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-support/talloc/talloc/install-swig-interface-in-SWINGLIBDIR.patch2
-rw-r--r--meta-oe/recipes-support/talloc/talloc_2.0.1.bb5
2 files changed, 4 insertions, 3 deletions
diff --git a/meta-oe/recipes-support/talloc/talloc/install-swig-interface-in-SWINGLIBDIR.patch b/meta-oe/recipes-support/talloc/talloc/install-swig-interface-in-SWINGLIBDIR.patch
index e1339a078e..635c60e461 100644
--- a/meta-oe/recipes-support/talloc/talloc/install-swig-interface-in-SWINGLIBDIR.patch
+++ b/meta-oe/recipes-support/talloc/talloc/install-swig-interface-in-SWINGLIBDIR.patch
@@ -17,7 +17,7 @@ Index: talloc-2.0.1/talloc.mk
- which swig >/dev/null 2>&1 && ${INSTALLCMD} -d $(DESTDIR)`swig -swiglib` || true
- which swig >/dev/null 2>&1 && ${INSTALLCMD} -m 644 talloc.i $(DESTDIR)`swig -swiglib` || true
+ which swig >/dev/null 2>&1 && ${INSTALLCMD} -d $(DESTDIR)/$(SWIGLIBDIR) || true
-+ which swig >/dev/null 2>&1 && ${INSTALLCMD} -m 644 talloc.i $(DESTDIR)/$(SWIGLIBDIR) || true
++ which swig >/dev/null 2>&1 && ${INSTALLCMD} -m 644 $(srcdir)/$(tallocdir)/talloc.i $(DESTDIR)/$(SWIGLIBDIR) || true
doc:: talloc.3 talloc.3.html
diff --git a/meta-oe/recipes-support/talloc/talloc_2.0.1.bb b/meta-oe/recipes-support/talloc/talloc_2.0.1.bb
index 48c0915997..9cf3e43224 100644
--- a/meta-oe/recipes-support/talloc/talloc_2.0.1.bb
+++ b/meta-oe/recipes-support/talloc/talloc_2.0.1.bb
@@ -18,10 +18,12 @@ PR = "r2"
EXTRA_AUTORECONF = "--exclude=autopoint --exclude=aclocal"
+DEPENDS += "swig-native"
+
do_install_prepend() {
# Hack the way swig interface for talloc is installed
# This hack is accompanied by install-swig-interface-in-SWINGLIBDIR.patch
- type swig > /dev/null 2>&1 && SWIGLIBDIR=`swig -swiglib` && SWIGLIBDIR=${SWIGLIBDIR##${STAGING_DIR_NATIVE}} && export SWIGLIBDIR || echo "No swig found"
+ type swig > /dev/null 2>&1 && SWIGLIBDIR=`swig -swiglib` && SWIGLIBDIR=`readlink -f ${SWIGLIBDIR}` && SWIGLIBDIR=${SWIGLIBDIR##${STAGING_DIR_NATIVE}} && export SWIGLIBDIR || echo "No swig found"
}
do_install_append() {
@@ -29,7 +31,6 @@ do_install_append() {
ln -s libtalloc.so.2.0.1 ${D}${libdir}/libtalloc.so.2.0
ln -s libtalloc.so.2.0 ${D}${libdir}/libtalloc.so.2
ln -s libtalloc.so.2 ${D}${libdir}/libtalloc.so
- rmdir ${D}${bindir}
}
PACKAGES += "${PN}-swig"