aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2017-07-27 04:44:21 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2017-08-13 13:19:40 +0200
commit888970ac7cd10c779542fb5000f784bca8f61d1e (patch)
tree55406baab42c43e95e86cca7b09f4f60a1dd058e
parentfcfa955fcb030c84a0362e113be506030c65b06c (diff)
downloadmeta-openembedded-contrib-888970ac7cd10c779542fb5000f784bca8f61d1e.tar.gz
glade: fix host contamination on centos7
Since gobject-introspection convert to python3 in oe-core, incorrectly assigning PYTHON_PN with python caused host python3 loaded. On centos7, built with qemuarm failed: ... arm-poky-linux-gnueabi-gcc: error: unrecognized argument in option '-mtune=generic' .. arm-poky-linux-gnueabi-gcc: error: unrecognized command line option '-m64' Traceback (most recent call last): File "/usr/lib64/python3.4/distutils/unixccompiler.py", line 126, in _compile ... The native python3 should be loaded. Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-devtools/glade/glade_3.20.0.bb4
1 files changed, 1 insertions, 3 deletions
diff --git a/meta-oe/recipes-devtools/glade/glade_3.20.0.bb b/meta-oe/recipes-devtools/glade/glade_3.20.0.bb
index 8b35a9c490..f33b6e31b0 100644
--- a/meta-oe/recipes-devtools/glade/glade_3.20.0.bb
+++ b/meta-oe/recipes-devtools/glade/glade_3.20.0.bb
@@ -9,7 +9,7 @@ DEPENDS = "gtk+ gtk+3 glib-2.0 libxml2 intltool-native \
"
-inherit autotools pkgconfig pythonnative gnomebase gobject-introspection
+inherit autotools pkgconfig gnomebase gobject-introspection
SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/glade/3.20/glade-${PV}.tar.xz \
file://remove-yelp-help-rules-var.patch \
@@ -23,5 +23,3 @@ FILES_${PN} += "${datadir}/* ${libdir}/glade/modules/libgladegtk.so"
FILES_${PN}-dev += "${libdir}/glade/modules/libgladegtk.la"
FILES_${PN}-dbg += "${libdir}/glade/modules/.debug/libgladegtk.so"
-PYTHON_PN = "python"
-