aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2017-02-11 19:33:14 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2017-02-13 18:44:35 +0100
commit7f3176f6288516fb79378c3e6ec4c03fa1a8c98d (patch)
tree9b2e91f290c52751640596fb5a77c7d6f86d68c6
parent00ba7da845b96a15b42550d15a343f7bc36392f8 (diff)
downloadmeta-openembedded-contrib-7f3176f6288516fb79378c3e6ec4c03fa1a8c98d.tar.gz
recipes: blacklist recipes runtime depending on blacklisted recipes
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-efl/recipes-efl/e17/e-wm-theme-b-and-w_svn.bb6
-rw-r--r--meta-efl/recipes-efl/e17/e-wm-theme-illume-efenniht_svn.bb4
-rw-r--r--meta-efl/recipes-efl/packagegroups/packagegroup-efl-sdk.bb2
-rw-r--r--meta-efl/recipes-efl/packagegroups/packagegroup-efl-standalone-sdk-target.bb2
-rw-r--r--meta-efl/recipes-efl/packagegroups/packagegroup-x11-illume.bb6
-rw-r--r--meta-multimedia/recipes-mediacenter/kodi/kodi-startup.bb4
-rw-r--r--meta-oe/recipes-benchmark/phoronix-test-suite/phoronix-test-suite_6.6.1.bb2
-rw-r--r--meta-oe/recipes-core/packagegroups/packagegroup-cli-tools.bb4
-rw-r--r--meta-oe/recipes-graphics/xorg-font/xorg-fonts-100dpi.bb10
-rw-r--r--meta-oe/recipes-support/usb-modeswitch/usb-modeswitch-data_20140529.bb4
-rw-r--r--meta-python/recipes-devtools/python/python3-pymisp_2.4.54.bb4
-rw-r--r--meta-python/recipes-devtools/python/python3-requests_2.13.0.bb4
-rw-r--r--meta-xfce/recipes-apps/ristretto/ristretto_0.8.1.bb6
-rw-r--r--meta-xfce/recipes-multimedia/packagegroups/packagegroup-xfce-multimedia.bb6
-rw-r--r--meta-xfce/recipes-multimedia/xfce4-mpc-plugin/xfce4-mpc-plugin_0.5.0.bb6
-rw-r--r--meta-xfce/recipes-multimedia/xfmpc/xfmpc_0.2.3.bb6
-rw-r--r--meta-xfce/recipes-panel-plugins/whiskermenu/xfce4-whiskermenu-plugin_2.0.3.bb2
-rw-r--r--meta-xfce/recipes-xfce/packagegroups/packagegroup-xfce-extended.bb6
18 files changed, 84 insertions, 0 deletions
diff --git a/meta-efl/recipes-efl/e17/e-wm-theme-b-and-w_svn.bb b/meta-efl/recipes-efl/e17/e-wm-theme-b-and-w_svn.bb
index 704e43dd6f..f75f9ead5a 100644
--- a/meta-efl/recipes-efl/e17/e-wm-theme-b-and-w_svn.bb
+++ b/meta-efl/recipes-efl/e17/e-wm-theme-b-and-w_svn.bb
@@ -29,3 +29,9 @@ do_install() {
}
FILES_${PN} = "${datadir}/enlightenment/data/themes/"
+
+PNBLACKLIST[e-wm-theme-b-and-w] ?= "Runtime depends on blacklisted e-wm"
+
+PNBLACKLIST[e-wm-theme-b-and-w] ?= "Runtime depends on blacklisted e-wm-theme-b-and-w"
+
+PNBLACKLIST[e-wm-theme-b-and-w] ?= "Runtime depends on blacklisted e-wm-theme-b-and-w-dev"
diff --git a/meta-efl/recipes-efl/e17/e-wm-theme-illume-efenniht_svn.bb b/meta-efl/recipes-efl/e17/e-wm-theme-illume-efenniht_svn.bb
index 965e4e995a..6032f20359 100644
--- a/meta-efl/recipes-efl/e17/e-wm-theme-illume-efenniht_svn.bb
+++ b/meta-efl/recipes-efl/e17/e-wm-theme-illume-efenniht_svn.bb
@@ -33,3 +33,7 @@ do_install() {
}
FILES_${PN} = "${datadir}/enlightenment/data/themes/"
+
+PNBLACKLIST[e-wm-theme-illume-efenniht] ?= "Runtime depends on blacklisted e-wm"
+
+PNBLACKLIST[e-wm-theme-illume-efenniht] ?= "Runtime depends on blacklisted e-wm-theme-illume-efenniht"
diff --git a/meta-efl/recipes-efl/packagegroups/packagegroup-efl-sdk.bb b/meta-efl/recipes-efl/packagegroups/packagegroup-efl-sdk.bb
index 5ead412ef7..8c42dbd085 100644
--- a/meta-efl/recipes-efl/packagegroups/packagegroup-efl-sdk.bb
+++ b/meta-efl/recipes-efl/packagegroups/packagegroup-efl-sdk.bb
@@ -15,3 +15,5 @@ RDEPENDS_${PN} = "\
packagegroup-core-sdk \
${SDK-EFL} \
${SDK-EXTRAS}"
+
+PNBLACKLIST[packagegroup-efl-sdk] ?= "Runtime depends on blacklisted elementary-dev"
diff --git a/meta-efl/recipes-efl/packagegroups/packagegroup-efl-standalone-sdk-target.bb b/meta-efl/recipes-efl/packagegroups/packagegroup-efl-standalone-sdk-target.bb
index 6a3f33dc68..8aed43a2e7 100644
--- a/meta-efl/recipes-efl/packagegroups/packagegroup-efl-standalone-sdk-target.bb
+++ b/meta-efl/recipes-efl/packagegroups/packagegroup-efl-standalone-sdk-target.bb
@@ -15,3 +15,5 @@ RDEPENDS_${PN} = "\
packagegroup-core-standalone-sdk-target \
${SDK-EFL} \
${SDK-EXTRAS}"
+
+PNBLACKLIST[packagegroup-efl-standalone-sdk-target] ?= "Runtime depends on blacklisted elementary-dev"
diff --git a/meta-efl/recipes-efl/packagegroups/packagegroup-x11-illume.bb b/meta-efl/recipes-efl/packagegroups/packagegroup-x11-illume.bb
index 9997828680..2519da0998 100644
--- a/meta-efl/recipes-efl/packagegroups/packagegroup-x11-illume.bb
+++ b/meta-efl/recipes-efl/packagegroups/packagegroup-x11-illume.bb
@@ -22,3 +22,9 @@ RDEPENDS_${PN} = "\
e-wm \
${ECONFIG} \
"
+
+PNBLACKLIST[packagegroup-x11-illume] ?= "Runtime depends on blacklisted e-wm"
+
+PNBLACKLIST[packagegroup-x11-illume] ?= "Runtime depends on blacklisted e-wm-config-mobile"
+
+PNBLACKLIST[packagegroup-x11-illume] ?= "Runtime depends on blacklisted e-wm-theme-default"
diff --git a/meta-multimedia/recipes-mediacenter/kodi/kodi-startup.bb b/meta-multimedia/recipes-mediacenter/kodi/kodi-startup.bb
index 955d02bf7f..49e0b4dc85 100644
--- a/meta-multimedia/recipes-mediacenter/kodi/kodi-startup.bb
+++ b/meta-multimedia/recipes-mediacenter/kodi/kodi-startup.bb
@@ -18,3 +18,7 @@ SYSTEMD_PACKAGES = "${PN}"
SYSTEMD_SERVICE_${PN} = "kodi.service"
RDEPENDS_${PN} += "xinit kodi"
+
+PNBLACKLIST[kodi-startup] ?= "Runtime depends on blacklisted kodi"
+
+PNBLACKLIST[kodi-startup] ?= "Runtime depends on blacklisted kodi-startup-dev"
diff --git a/meta-oe/recipes-benchmark/phoronix-test-suite/phoronix-test-suite_6.6.1.bb b/meta-oe/recipes-benchmark/phoronix-test-suite/phoronix-test-suite_6.6.1.bb
index 1f14048493..bdd444a4f5 100644
--- a/meta-oe/recipes-benchmark/phoronix-test-suite/phoronix-test-suite_6.6.1.bb
+++ b/meta-oe/recipes-benchmark/phoronix-test-suite/phoronix-test-suite_6.6.1.bb
@@ -34,3 +34,5 @@ FILES_${PN} += " \
${datadir}/mime/packages/openbenchmarking-mime.xml \
${systemd_unitdir}/* \
"
+
+PNBLACKLIST[phoronix-test-suite] ?= "Runtime depends on blacklisted php-cli"
diff --git a/meta-oe/recipes-core/packagegroups/packagegroup-cli-tools.bb b/meta-oe/recipes-core/packagegroups/packagegroup-cli-tools.bb
index 2a4b067ba2..1bb56ea30f 100644
--- a/meta-oe/recipes-core/packagegroups/packagegroup-cli-tools.bb
+++ b/meta-oe/recipes-core/packagegroups/packagegroup-cli-tools.bb
@@ -43,3 +43,7 @@ RDEPENDS_${PN}-debug = "\
RRECOMMENDS_${PN}-debug = "\
ltrace \
"
+
+PNBLACKLIST[packagegroup-cli-tools] ?= "Runtime depends on blacklisted dbus-daemon-proxy"
+
+PNBLACKLIST[packagegroup-cli-tools] ?= "Runtime depends on blacklisted packagegroup-cli-tools"
diff --git a/meta-oe/recipes-graphics/xorg-font/xorg-fonts-100dpi.bb b/meta-oe/recipes-graphics/xorg-font/xorg-fonts-100dpi.bb
index 45e3f7b592..0e1164dd14 100644
--- a/meta-oe/recipes-graphics/xorg-font/xorg-fonts-100dpi.bb
+++ b/meta-oe/recipes-graphics/xorg-font/xorg-fonts-100dpi.bb
@@ -12,3 +12,13 @@ RDEPENDS_${PN} = "\
font-bh-lucidatypewriter-100dpi \
font-bitstream-100dpi \
"
+
+PNBLACKLIST[xorg-fonts-100dpi] ?= "Runtime depends on blacklisted font-adobe-100dpi"
+
+PNBLACKLIST[xorg-fonts-100dpi] ?= "Runtime depends on blacklisted xorg-fonts-100dpi"
+
+PNBLACKLIST[xorg-fonts-100dpi] ?= "Runtime depends on blacklisted font-bh-100dpi"
+
+PNBLACKLIST[xorg-fonts-100dpi] ?= "Runtime depends on blacklisted font-adobe-utopia-100dpi"
+
+PNBLACKLIST[xorg-fonts-100dpi] ?= "Runtime depends on blacklisted font-bh-lucidatypewriter-100dpi"
diff --git a/meta-oe/recipes-support/usb-modeswitch/usb-modeswitch-data_20140529.bb b/meta-oe/recipes-support/usb-modeswitch/usb-modeswitch-data_20140529.bb
index a265411c1e..434f68a1d8 100644
--- a/meta-oe/recipes-support/usb-modeswitch/usb-modeswitch-data_20140529.bb
+++ b/meta-oe/recipes-support/usb-modeswitch/usb-modeswitch-data_20140529.bb
@@ -15,3 +15,7 @@ do_install() {
RDEPENDS_${PN} = "usb-modeswitch (>= 2.2.0)"
FILES_${PN} += "${base_libdir}/udev/rules.d/ \
${datadir}/usb_modeswitch"
+
+PNBLACKLIST[usb-modeswitch-data] ?= "Runtime depends on blacklisted usb-modeswitch"
+
+PNBLACKLIST[usb-modeswitch-data] ?= "Runtime depends on blacklisted usb-modeswitch-data"
diff --git a/meta-python/recipes-devtools/python/python3-pymisp_2.4.54.bb b/meta-python/recipes-devtools/python/python3-pymisp_2.4.54.bb
index 4523d9e30a..582d01d592 100644
--- a/meta-python/recipes-devtools/python/python3-pymisp_2.4.54.bb
+++ b/meta-python/recipes-devtools/python/python3-pymisp_2.4.54.bb
@@ -1,2 +1,6 @@
inherit pypi setuptools3
require python-pymisp.inc
+
+PNBLACKLIST[python3-pymisp] ?= "Runtime depends on blacklisted python3-pymisp"
+
+PNBLACKLIST[python3-pymisp] ?= "Runtime depends on blacklisted python3-pymisp-dev"
diff --git a/meta-python/recipes-devtools/python/python3-requests_2.13.0.bb b/meta-python/recipes-devtools/python/python3-requests_2.13.0.bb
index 5e869b7883..bbfbfeb8a8 100644
--- a/meta-python/recipes-devtools/python/python3-requests_2.13.0.bb
+++ b/meta-python/recipes-devtools/python/python3-requests_2.13.0.bb
@@ -3,3 +3,7 @@ require python-requests.inc
# Add the runtime depends for selectors.py
RDEPENDS_${PN} += "${PYTHON_PN}-misc"
+
+PNBLACKLIST[python3-requests] ?= "Runtime depends on blacklisted python3-ndg-httpsclient"
+
+PNBLACKLIST[python3-requests] ?= "Runtime depends on blacklisted python3-requests-dev"
diff --git a/meta-xfce/recipes-apps/ristretto/ristretto_0.8.1.bb b/meta-xfce/recipes-apps/ristretto/ristretto_0.8.1.bb
index 7abf186874..1aaf549662 100644
--- a/meta-xfce/recipes-apps/ristretto/ristretto_0.8.1.bb
+++ b/meta-xfce/recipes-apps/ristretto/ristretto_0.8.1.bb
@@ -13,3 +13,9 @@ SRC_URI[md5sum] = "5332876b627b3237eebb76db66e2fb11"
SRC_URI[sha256sum] = "0b4c90c585166c958d479075b98da6e28ca500bda6f4d3443f20e0a2172030ee"
FILES_${PN} += "${datadir}/appdata"
+
+PNBLACKLIST[ristretto] ?= "Runtime depends on blacklisted tumbler"
+
+PNBLACKLIST[ristretto] ?= "Runtime depends on blacklisted ristretto-dev"
+
+PNBLACKLIST[ristretto] ?= "Runtime depends on blacklisted ristretto"
diff --git a/meta-xfce/recipes-multimedia/packagegroups/packagegroup-xfce-multimedia.bb b/meta-xfce/recipes-multimedia/packagegroups/packagegroup-xfce-multimedia.bb
index 72a96f3c27..9377798d36 100644
--- a/meta-xfce/recipes-multimedia/packagegroups/packagegroup-xfce-multimedia.bb
+++ b/meta-xfce/recipes-multimedia/packagegroups/packagegroup-xfce-multimedia.bb
@@ -9,3 +9,9 @@ RDEPENDS_${PN} = " \
xfmpc \
xfce4-mpc-plugin \
"
+
+PNBLACKLIST[packagegroup-xfce-multimedia] ?= "Runtime depends on blacklisted xfce4-mpc-plugin"
+
+PNBLACKLIST[packagegroup-xfce-multimedia] ?= "Runtime depends on blacklisted packagegroup-xfce-multimedia"
+
+PNBLACKLIST[packagegroup-xfce-multimedia] ?= "Runtime depends on blacklisted xfmpc"
diff --git a/meta-xfce/recipes-multimedia/xfce4-mpc-plugin/xfce4-mpc-plugin_0.5.0.bb b/meta-xfce/recipes-multimedia/xfce4-mpc-plugin/xfce4-mpc-plugin_0.5.0.bb
index f709e4da95..105302e52b 100644
--- a/meta-xfce/recipes-multimedia/xfce4-mpc-plugin/xfce4-mpc-plugin_0.5.0.bb
+++ b/meta-xfce/recipes-multimedia/xfce4-mpc-plugin/xfce4-mpc-plugin_0.5.0.bb
@@ -13,3 +13,9 @@ RRECOMMENDS_${PN} = "mpd"
SRC_URI[md5sum] = "13d5d95ef0c305bac45fde6231258e5d"
SRC_URI[sha256sum] = "f1320916ae3112e6825699652a502cebfa78bb006c649b42d3d331dfe57b6cb0"
+
+PNBLACKLIST[xfce4-mpc-plugin] ?= "Runtime depends on blacklisted mpd"
+
+PNBLACKLIST[xfce4-mpc-plugin] ?= "Runtime depends on blacklisted xfce4-mpc-plugin"
+
+PNBLACKLIST[xfce4-mpc-plugin] ?= "Runtime depends on blacklisted xfce4-mpc-plugin-dev"
diff --git a/meta-xfce/recipes-multimedia/xfmpc/xfmpc_0.2.3.bb b/meta-xfce/recipes-multimedia/xfmpc/xfmpc_0.2.3.bb
index 3d902a17bf..19166f59af 100644
--- a/meta-xfce/recipes-multimedia/xfmpc/xfmpc_0.2.3.bb
+++ b/meta-xfce/recipes-multimedia/xfmpc/xfmpc_0.2.3.bb
@@ -11,3 +11,9 @@ inherit xfce-app
SRC_URI[md5sum] = "e2d2faeb7a6f62813e287f3d12522b71"
SRC_URI[sha256sum] = "4189c0c82b66b758a6d5bc651493b675d3d46329e5f1a76ff26c448125f4fcb0"
+
+PNBLACKLIST[xfmpc] ?= "Runtime depends on blacklisted mpd"
+
+PNBLACKLIST[xfmpc] ?= "Runtime depends on blacklisted xfmpc-dev"
+
+PNBLACKLIST[xfmpc] ?= "Runtime depends on blacklisted xfmpc"
diff --git a/meta-xfce/recipes-panel-plugins/whiskermenu/xfce4-whiskermenu-plugin_2.0.3.bb b/meta-xfce/recipes-panel-plugins/whiskermenu/xfce4-whiskermenu-plugin_2.0.3.bb
index 9feb864b4e..b68ecdb3da 100644
--- a/meta-xfce/recipes-panel-plugins/whiskermenu/xfce4-whiskermenu-plugin_2.0.3.bb
+++ b/meta-xfce/recipes-panel-plugins/whiskermenu/xfce4-whiskermenu-plugin_2.0.3.bb
@@ -9,3 +9,5 @@ SRC_URI[md5sum] = "3cbbe6f233089b6923113f47d311f875"
SRC_URI[sha256sum] = "1b7afb233c74c33f0ee26de6514c4168497f4aa584dc2f6778dff15d8d47b165"
RRECOMMENDS_${PN} += "menulibre"
+
+PNBLACKLIST[xfce4-whiskermenu-plugin] ?= "Runtime depends on blacklisted menulibre"
diff --git a/meta-xfce/recipes-xfce/packagegroups/packagegroup-xfce-extended.bb b/meta-xfce/recipes-xfce/packagegroups/packagegroup-xfce-extended.bb
index c07188f6e0..9aaa2f31ff 100644
--- a/meta-xfce/recipes-xfce/packagegroups/packagegroup-xfce-extended.bb
+++ b/meta-xfce/recipes-xfce/packagegroups/packagegroup-xfce-extended.bb
@@ -66,3 +66,9 @@ RRECOMMENDS_${PN} = " \
xfce4-taskmanager \
gigolo \
"
+
+PNBLACKLIST[packagegroup-xfce-extended] ?= "Runtime depends on blacklisted xfce4-mixer"
+
+PNBLACKLIST[packagegroup-xfce-extended] ?= "Runtime depends on blacklisted xfce4-verve-plugin"
+
+PNBLACKLIST[packagegroup-xfce-extended] ?= "Runtime depends on blacklisted ristretto"