aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJason Wessel <jason.wessel@windriver.com>2017-07-25 08:23:22 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-08-13 13:19:02 +0200
commit664e550c767547fb0767c48a48e6b74a54cf4c78 (patch)
tree9e3c701e2633e1500733b421a2a0e66174345a9e
parentb0ccd810d717bf8d448ac9b620318de95e571095 (diff)
downloadmeta-openembedded-contrib-664e550c767547fb0767c48a48e6b74a54cf4c78.tar.gz
meta-openembedded-contrib-664e550c767547fb0767c48a48e6b74a54cf4c78.tar.bz2
meta-openembedded-contrib-664e550c767547fb0767c48a48e6b74a54cf4c78.zip
gvfs: Fix build regression from uprev
The commit 187798c3bd3dad2de3d159faf456aa6e71fbdf46 (gvfs: update 1.28.3 -> 1.32.1) caused a regression where images that use rpm4 can no longer assemble correctly because it includes polkit rules. At image creation time rpm4 will detect a mismatch of the ownership with the polkit rules.d directory as follows: file /usr/share/polkit-1/rules.d conflicts between attempted installs of gvfs-1.32.1-r0.1.core2_64 and polkit-0.113-r0.8.core2_64 file /usr/share/polkit-1/rules.d conflicts between attempted installs of libvirt-1.3.5-r0.9.core2_64 and gvfs-1.32.1-r0.1.core2_64 The libvirt which also appears in the error message has already been fixed in the meta-virtualization layer in a similar maner. (http://git.yoctoproject.org/cgit/cgit.cgi/meta-virtualization/commit/?id=67c86c4962170354ad8a2ec4cdbb9bc0056cfd66) Signed-off-by: Jason Wessel <jason.wessel@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-gnome/recipes-gnome/gvfs/gvfs_1.32.1.bb8
1 files changed, 7 insertions, 1 deletions
diff --git a/meta-gnome/recipes-gnome/gvfs/gvfs_1.32.1.bb b/meta-gnome/recipes-gnome/gvfs/gvfs_1.32.1.bb
index 94d89542e5..d38068836c 100644
--- a/meta-gnome/recipes-gnome/gvfs/gvfs_1.32.1.bb
+++ b/meta-gnome/recipes-gnome/gvfs/gvfs_1.32.1.bb
@@ -4,7 +4,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=05df38dd77c35ec8431f212410a3329e"
inherit gnome bash-completion gettext
-DEPENDS += "libsecret glib-2.0 gconf intltool-native libgudev udisks2"
+DEPENDS += "libsecret glib-2.0 gconf intltool-native libgudev udisks2 polkit shadow-native"
SRC_URI = "https://download.gnome.org/sources/${BPN}/${@gnome_verdir("${PV}")}/${BPN}-${PV}.tar.xz;name=archive"
@@ -58,3 +58,9 @@ PACKAGECONFIG[fuse] = "--enable-fuse, --disable-fuse, fuse"
# libcdio-paranoia recipe doesn't exist yet
PACKAGECONFIG[cdda] = "--enable-cdda, --disable-cdda, libcdio-paranoia"
+
+# Fix up permissions on polkit rules.d to work with rpm4 constraints
+do_install_append() {
+ chmod 700 ${D}/${datadir}/polkit-1/rules.d
+ chown polkitd:root ${D}/${datadir}/polkit-1/rules.d
+}