aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2016-06-09 14:54:43 -0400
committerJoe MacDonald <joe_macdonald@mentor.com>2016-06-15 19:52:22 -0400
commit5c8efcc9f54d04ac9a7c41176989efb78c4ac54f (patch)
tree9133a8fb57f4490de322baa84d8bd978d0e30fb8
parentf316c4a32686e57c4b65e659fbf7d7936ac39ff6 (diff)
downloadmeta-openembedded-contrib-5c8efcc9f54d04ac9a7c41176989efb78c4ac54f.tar.gz
curlpp: fix build with gcc-6 and remove blacklist
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
-rw-r--r--meta-networking/recipes-support/curlpp/curlpp_0.7.3.bb7
1 files changed, 4 insertions, 3 deletions
diff --git a/meta-networking/recipes-support/curlpp/curlpp_0.7.3.bb b/meta-networking/recipes-support/curlpp/curlpp_0.7.3.bb
index 43e69b93ae..78b943247d 100644
--- a/meta-networking/recipes-support/curlpp/curlpp_0.7.3.bb
+++ b/meta-networking/recipes-support/curlpp/curlpp_0.7.3.bb
@@ -16,6 +16,10 @@ SRC_URI[sha256sum] = "e3f9427b27c5bddf898d383d45c0d3d5397e2056ff935d9a5cdaef6a9a
inherit autotools-brokensep pkgconfig binconfig
+# Upstream is currently working on porting the code to use std::unique_ptr instead of the
+# deprecated auto_ptr. For now, ignore the issue.
+CXXFLAGS += "-Wno-error=deprecated-declarations"
+
PACKAGES =+ "libcurlpp libcurlpp-dev libcurlpp-staticdev"
FILES_lib${BPN} = "${libdir}/lib*.so.* \
@@ -29,6 +33,3 @@ FILES_lib${BPN}-dev = "${includedir} \
FILES_lib${BPN}-staticdev = "${libdir}/lib*.a"
BBCLASSEXTEND = "native nativesdk"
-
-# http://errors.yoctoproject.org/Errors/Details/68623/
-PNBLACKLIST[curlpp] ?= "BROKEN: fails to build with gcc-6"