aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2015-11-20 02:05:10 -0800
committerArmin Kuster <akuster808@gmail.com>2015-12-20 14:16:19 -0800
commit6fa49f37634f97a202ed93cbe9e2fbd8d49cfd8c (patch)
tree8588799cef2435572878708879125b77fb1230ef
parent7ad5e2d13bd8daa9be77bbbcd84713ae7ef1f399 (diff)
downloadmeta-openembedded-contrib-6fa49f37634f97a202ed93cbe9e2fbd8d49cfd8c.tar.gz
dracut: fix host-user-contaminated
Fixed: dracut-043+giteab03540cd695d940062af5b55c02e8829aaa526: dracut: /dracut/usr/lib/dracut/modules.d/99img-lib/img-lib.sh is owned by uid 15220, which is the same as the user running bitbake. This may be due to host contamination [host-user-contaminated] lib32-dracut-043+giteab03540cd695d940062af5b55c02e8829aaa526: lib32-dracut: /lib32-dracut/usr/lib/dracut/modules.d/99img-lib/img-lib.sh is owned by uid 15220, which is the same as the user running bitbake. This may be due to host contamination [host-user-contaminated] Its Makefile uses cp -arx to install modules.d, so fix the owner to root:root Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-initramfs/recipes-devtools/dracut/dracut_git.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta-initramfs/recipes-devtools/dracut/dracut_git.bb b/meta-initramfs/recipes-devtools/dracut/dracut_git.bb
index 91a83214db..e026da7101 100644
--- a/meta-initramfs/recipes-devtools/dracut/dracut_git.bb
+++ b/meta-initramfs/recipes-devtools/dracut/dracut_git.bb
@@ -36,6 +36,9 @@ do_configure() {
do_install() {
oe_runmake install DESTDIR=${D}
+ # Its Makefile uses cp -arx to install modules.d, so fix the owner
+ # to root:root
+ chown -R root:root ${D}/${prefix}/lib/dracut/modules.d
}
PACKAGES =+ "${PN}-bash-completion"