aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndre McCurdy <armccurdy@gmail.com>2015-11-16 20:23:25 -0800
committerArmin Kuster <akuster808@gmail.com>2015-12-20 14:28:52 -0800
commit655b9806ebcadfc01eca5f1ba075067295e8a45f (patch)
tree141062133fe3f2c6a883f4fe8ee4fefcb457a756
parent05f285254f276c98e84c7f34a6586141acfa8d05 (diff)
downloadmeta-openembedded-contrib-655b9806ebcadfc01eca5f1ba075067295e8a45f.tar.gz
tree: respect the package's own default CFLAGS
The tree Makefile defines default CFLAGS form Linux (-DLINUX, etc) which are lost if we don't manually include them in the final CFLAGS. Also break the dependency on EXTRA_OEMAKE containing '-e', disable the unused configure task and, since package has a very short description, set SUMMARY instead of DESCRIPTION. Signed-off-by: Andre McCurdy <armccurdy@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-support/tree/tree_1.7.0.bb11
1 files changed, 9 insertions, 2 deletions
diff --git a/meta-oe/recipes-support/tree/tree_1.7.0.bb b/meta-oe/recipes-support/tree/tree_1.7.0.bb
index 507b12a397..2e8ebdb4d9 100644
--- a/meta-oe/recipes-support/tree/tree_1.7.0.bb
+++ b/meta-oe/recipes-support/tree/tree_1.7.0.bb
@@ -1,4 +1,4 @@
-DESCRIPTION = "a recursive directory listing command"
+SUMMARY = "A recursive directory listing command"
HOMEPAGE = "http://mama.indstate.edu/users/ice/tree/"
SECTION = "console/utils"
LICENSE = "GPLv2"
@@ -8,7 +8,14 @@ SRC_URI = "ftp://mama.indstate.edu/linux/${BPN}/${BP}.tgz"
SRC_URI[md5sum] = "abe3e03e469c542d8e157cdd93f4d8a6"
SRC_URI[sha256sum] = "6957c20e82561ac4231638996e74f4cfa4e6faabc5a2f511f0b4e3940e8f7b12"
+# tree's default CFLAGS for Linux
+CFLAGS += "-Wall -DLINUX -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64"
+
+EXTRA_OEMAKE = "CC='${CC}' CFLAGS='${CFLAGS}' LDFLAGS='${LDFLAGS}'"
+
+do_configure[noexec] = "1"
+
do_install() {
install -d ${D}${bindir}
- install -m 0755 ${S}/${BPN} ${D}${bindir}/${BPN}
+ install -m 0755 ${S}/${BPN} ${D}${bindir}/
}