aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Patterson <pattersonc@ainfosec.com>2015-12-18 15:49:41 -0500
committerMartin Jansa <Martin.Jansa@gmail.com>2016-01-14 11:22:08 +0100
commit59cefade1d8dfd6a941d2053aeef1c784f29cb08 (patch)
tree0e774c649072b498193a33c24c4ac6a2ed7d5094
parent5556fb4d26cd40b5bc49f8edfaa56c63ae7810b7 (diff)
downloadmeta-openembedded-contrib-59cefade1d8dfd6a941d2053aeef1c784f29cb08.tar.gz
strongswan: add configure patch fix for systemd
Fixes strongswan configure script for systemd >= 209, where it merged libsystemd-journal and libsystemd-daemon into libsystemd. Signed-off-by: Chris Patterson <pattersonc@ainfosec.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-networking/recipes-support/strongswan/files/support-newer-systemd.patch69
-rw-r--r--meta-networking/recipes-support/strongswan/strongswan_5.3.2.bb1
2 files changed, 70 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/strongswan/files/support-newer-systemd.patch b/meta-networking/recipes-support/strongswan/files/support-newer-systemd.patch
new file mode 100644
index 0000000000..550cf67581
--- /dev/null
+++ b/meta-networking/recipes-support/strongswan/files/support-newer-systemd.patch
@@ -0,0 +1,69 @@
+commit 82498129e0a91dfc3ed2c4ec3b2252f44655b83c
+Author: Chris Patterson <pattersonc@ainfosec.com>
+Date: Fri Dec 18 08:27:57 2015 -0500
+
+ configure: support systemd >= 209
+
+ libsystemd-journal and libsystemd-daemon are now just
+ part of libsystemd.
+
+ Keep original systemd checks as a fallback.
+
+ Updates charon-systemd/Makefile.am accordingly.
+
+ Tested on:
+ - debian wheezy (systemd v44)
+ - ubuntu 15.10 (systemd v255).
+
+ Signed-off-by: Chris Patterson <pattersonc@ainfosec.com>
+
+Upstream-Status: Submitted
+https://github.com/strongswan/strongswan/pull/24
+
+diff --git a/configure.ac b/configure.ac
+index 3d71ce0..f6c0426 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -941,13 +941,17 @@ if test x$systemd = xtrue; then
+ AC_MSG_ERROR([not found (try --with-systemdsystemunitdir)])
+ fi
+
+- PKG_CHECK_MODULES(systemd_daemon, [libsystemd-daemon])
+- AC_SUBST(systemd_daemon_CFLAGS)
+- AC_SUBST(systemd_daemon_LIBS)
+-
+- PKG_CHECK_MODULES(systemd_journal, [libsystemd-journal])
+- AC_SUBST(systemd_journal_CFLAGS)
+- AC_SUBST(systemd_journal_LIBS)
++ PKG_CHECK_MODULES(systemd, [libsystemd >= 209],
++ [AC_SUBST(systemd_CFLAGS)
++ AC_SUBST(systemd_LIBS)],
++ [PKG_CHECK_MODULES(systemd_daemon, [libsystemd-daemon])
++ AC_SUBST(systemd_daemon_CFLAGS)
++ AC_SUBST(systemd_daemon_LIBS)
++
++ PKG_CHECK_MODULES(systemd_journal, [libsystemd-journal])
++ AC_SUBST(systemd_journal_CFLAGS)
++ AC_SUBST(systemd_journal_LIBS)
++ ])
+ fi
+
+ if test x$tss = xtrousers; then
+diff --git a/src/charon-systemd/Makefile.am b/src/charon-systemd/Makefile.am
+index 1b9ac15..ee85d43 100644
+--- a/src/charon-systemd/Makefile.am
++++ b/src/charon-systemd/Makefile.am
+@@ -9,11 +9,11 @@ charon_systemd_CPPFLAGS = \
+ -I$(top_srcdir)/src/libstrongswan \
+ -I$(top_srcdir)/src/libhydra \
+ -I$(top_srcdir)/src/libcharon \
+- $(systemd_daemon_CFLAGS) $(systemd_journal_CFLAGS) \
++ $(systemd_CFLAGS) $(systemd_daemon_CFLAGS) $(systemd_journal_CFLAGS) \
+ -DPLUGINS=\""${charon_plugins}\""
+
+ charon_systemd_LDADD = \
+ $(top_builddir)/src/libstrongswan/libstrongswan.la \
+ $(top_builddir)/src/libhydra/libhydra.la \
+ $(top_builddir)/src/libcharon/libcharon.la \
+- $(systemd_daemon_LIBS) $(systemd_journal_LIBS) -lm $(PTHREADLIB) $(DLLIB)
++ $(systemd_LIBS) $(systemd_daemon_LIBS) $(systemd_journal_LIBS) -lm $(PTHREADLIB) $(DLLIB)
diff --git a/meta-networking/recipes-support/strongswan/strongswan_5.3.2.bb b/meta-networking/recipes-support/strongswan/strongswan_5.3.2.bb
index df7b4966c0..aa32383a40 100644
--- a/meta-networking/recipes-support/strongswan/strongswan_5.3.2.bb
+++ b/meta-networking/recipes-support/strongswan/strongswan_5.3.2.bb
@@ -9,6 +9,7 @@ DEPENDS = "gmp openssl flex-native flex bison-native"
SRC_URI = "http://download.strongswan.org/strongswan-${PV}.tar.bz2 \
file://fix-funtion-parameter.patch \
+ file://support-newer-systemd.patch \
"
SRC_URI[md5sum] = "fab014be1477ef4ebf9a765e10f8802c"