aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoshua Lock <joshua.lock@collabora.co.uk>2015-12-10 15:32:34 +0000
committerArmin Kuster <akuster808@gmail.com>2015-12-20 14:20:27 -0800
commit0afe8af234e791235236feb0d8c59a748c47a190 (patch)
tree99005f3c76a34a520e6337c9058debaf39014789
parent76df85bd1a672eb156e91a928e34cb9d25750b28 (diff)
downloadmeta-openembedded-contrib-0afe8af234e791235236feb0d8c59a748c47a190.tar.gz
poppler-data: install CMap resources for CJK glyph support
CID-keyed fonts, as commonly used to support pictographic East Asian character sets require Character Maps which unidirectionally map character codes (i.e. Unicode encoding) to CID (the glyphs in the font face). Without a CMap poppler isn't able to correctly PDF files in Chinese, Japanese or Korean without embedded fonts. This change installs a copy of the Identity files from Adobe's CMap Resources[1] based on a similar change in Fedora's poppler-data[2][3]. This is an updated version of the v2 patch originally created and sent by my colleague, Joshua Lock. 1. https://github.com/adobe-type-tools/cmap-resources 2. http://pkgs.fedoraproject.org/cgit/poppler-data.git/tree/poppler-data.spec#n18 3. https://bugzilla.redhat.com/show_bug.cgi?id=842351 Co-Authored-By: Bob Ham <bob.ham@collabora.com> Signed-off-by: Bob Ham <bob.ham@collabora.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-support/poppler/poppler-data_0.4.7.bb21
1 files changed, 18 insertions, 3 deletions
diff --git a/meta-oe/recipes-support/poppler/poppler-data_0.4.7.bb b/meta-oe/recipes-support/poppler/poppler-data_0.4.7.bb
index 4f55e9f2d1..27c4110283 100644
--- a/meta-oe/recipes-support/poppler/poppler-data_0.4.7.bb
+++ b/meta-oe/recipes-support/poppler/poppler-data_0.4.7.bb
@@ -1,5 +1,7 @@
-SUMMARY = "Poppler is a PDF rendering library based on the xpdf-3.0 code base"
-LICENSE = "Adobe"
+SUMMARY = "Encoding files for Poppler"
+DESCRIPTION = "Encoding files for use with poppler that enable poppler to \
+ correctly render CJK and Cyrrilic."
+LICENSE = "BSD & GPLv2 & GPLv3+"
LIC_FILES_CHKSUM = "file://COPYING;md5=4870b98343f0bbb25fa43b9d2ba59448 \
file://COPYING.adobe;md5=63c6a8a9df204c00461fa5f163d8a663 \
file://COPYING.gpl2;md5=751419260aa954499f7abaabaa882bbe \
@@ -7,15 +9,28 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=4870b98343f0bbb25fa43b9d2ba59448 \
inherit allarch
-SRC_URI = "http://poppler.freedesktop.org/${BP}.tar.gz"
+INHIBIT_DEFAULT_DEPS = "1"
+
+CMAP_RESOURCES_BASE = "https://github.com/adobe-type-tools/cmap-resources/raw/0561ebca035813ed04c3485bca636a0aa7abdc1d/cmapresources_identity-0/CMap"
+
+SRC_URI = "http://poppler.freedesktop.org/${BP}.tar.gz \
+ ${CMAP_RESOURCES_BASE}/Identity-H;name=idh \
+ ${CMAP_RESOURCES_BASE}/Identity-V;name=idv"
+
SRC_URI[md5sum] = "636a8f2b9f6df9e7ced8ec0946961eaf"
SRC_URI[sha256sum] = "e752b0d88a7aba54574152143e7bf76436a7ef51977c55d6bd9a48dccde3a7de"
+SRC_URI[idh.md5sum] = "009c93cf0141ab7bd6acb7eea14306cc"
+SRC_URI[idh.sha256sum] = "ae702c203a82ea124e9b96590f821db6fbf8754e2c4547a9dba0e82f94739e95"
+SRC_URI[idv.md5sum] = "2f32a45d43d001c26eeac6b878855fbf"
+SRC_URI[idv.sha256sum] = "89a85daf7031e93c883e76b9168a226dfd585bf5506e9e1956772163f15cb082"
do_compile() {
}
do_install() {
oe_runmake install DESTDIR=${D}
+ install -d ${D}${datadir}/poppler/cMap
+ install -m644 ${WORKDIR}/Identity-* ${D}${datadir}/poppler/cMap/
}
FILES_${PN} += "${datadir}"