aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGeorge McCollister <george.mccollister@gmail.com>2015-11-12 12:35:36 -0600
committerArmin Kuster <akuster808@gmail.com>2015-12-20 14:28:29 -0800
commit05f285254f276c98e84c7f34a6586141acfa8d05 (patch)
tree8bc9480c660fd3f74857a1e96292074f8bf932b0
parent9fc5f4b83188da24270097d1675557c3c3b95f4f (diff)
downloadmeta-openembedded-contrib-05f285254f276c98e84c7f34a6586141acfa8d05.tar.gz
postgresql: Don't symlink to perl if it's disabled
Don't create a symlink to libperl.so if perl isn't in PACKAGECONFIG. Attempting to do so will fail if perl hasn't been built. Signed-off-by: George McCollister <george.mccollister@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-support/postgresql/postgresql.inc18
1 files changed, 10 insertions, 8 deletions
diff --git a/meta-oe/recipes-support/postgresql/postgresql.inc b/meta-oe/recipes-support/postgresql/postgresql.inc
index f3ff22583a..dbc02a0134 100644
--- a/meta-oe/recipes-support/postgresql/postgresql.inc
+++ b/meta-oe/recipes-support/postgresql/postgresql.inc
@@ -141,14 +141,16 @@ do_configure() {
-e "/^TCLSH/s:=.*:= ${bindir}/tclsh:g" \
${B}/src/Makefile.global
- # workaround perl package's libperl.so problem
- # we are using perlnative so this perl should have same version
- perl_version=`perl -v 2>/dev/null | \
- sed -n 's/This is perl.*v[a-z ]*\([0-9]\.[0-9][0-9.]*\).*$/\1/p'`
- if [ ! -h "${STAGING_LIBDIR}/perl/$perl_version/CORE/libperl.so" -a \
- ! -h "${STAGING_LIBDIR}/libperl.so" ]; then
- ln -sf ../../../libperl.so.5 \
- ${STAGING_LIBDIR}/perl/$perl_version/CORE/libperl.so
+ if ${@bb.utils.contains('PACKAGECONFIG', 'perl', 'true', 'false', d)}; then
+ # workaround perl package's libperl.so problem
+ # we are using perlnative so this perl should have same version
+ perl_version=`perl -v 2>/dev/null | \
+ sed -n 's/This is perl.*v[a-z ]*\([0-9]\.[0-9][0-9.]*\).*$/\1/p'`
+ if [ ! -h "${STAGING_LIBDIR}/perl/$perl_version/CORE/libperl.so" -a \
+ ! -h "${STAGING_LIBDIR}/libperl.so" ]; then
+ ln -sf ../../../libperl.so.5 \
+ ${STAGING_LIBDIR}/perl/$perl_version/CORE/libperl.so
+ fi
fi
}