aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorQi.Chen@windriver.com <Qi.Chen@windriver.com>2015-10-08 13:02:49 +0800
committerJoe MacDonald <joe_macdonald@mentor.com>2015-10-21 15:59:03 -0400
commit9e75e3d136b83194496c3791cc9b43767c5a4396 (patch)
tree275cd7b07d83cf79cff7a09d1a5f803555dd52a2
parente8557c2d8da74c5e40151afc5cbbb1d9996c72dc (diff)
downloadmeta-openembedded-contrib-9e75e3d136b83194496c3791cc9b43767c5a4396.tar.gz
netmap-modules: fix compilation failure
If CONFIG_IXGBE is enabled in kernel. This package fails to build with error messages like below. | #error "unsupported ixgbe driver version" | ^ ....... error: request for member 'count' in something not a structure or union | na.num_rx_desc = NM_IXGBE_RX_RING(adapter, 0)->count; | ^ | cc1: some warnings being treated as errors Fix this problem by disabling igxbe driver in netmap-modules. Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
-rw-r--r--meta-networking/recipes-kernel/netmap/netmap-modules_git.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta-networking/recipes-kernel/netmap/netmap-modules_git.bb b/meta-networking/recipes-kernel/netmap/netmap-modules_git.bb
index f9ac9ccda1..c1c319d7ad 100644
--- a/meta-networking/recipes-kernel/netmap/netmap-modules_git.bb
+++ b/meta-networking/recipes-kernel/netmap/netmap-modules_git.bb
@@ -15,6 +15,8 @@ EXTRA_OECONF = "--kernel-dir=${STAGING_KERNEL_BUILDDIR} \
--driver-suffix="-netmap" \
"
+EXTRA_OECONF += "--no-drivers=ixgbe"
+
LDFLAGS := "${@'${LDFLAGS}'.replace('-Wl,-O1', '')}"
LDFLAGS := "${@'${LDFLAGS}'.replace('-Wl,--as-needed', '')}"