aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2015-10-13 12:43:09 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2015-10-23 12:53:22 +0200
commit796f9ba6a6e3ba9d315b62d8e9f7f0873fe95b7c (patch)
tree0f4447e09be8fa7febe3c9d8f88c1206503e5f16
parent29e99a67da917efe3f7c41a4701fa78334ab4df5 (diff)
downloadmeta-openembedded-contrib-796f9ba6a6e3ba9d315b62d8e9f7f0873fe95b7c.tar.gz
debootstrap: cleanup the recipe
* FILESEXTRAPATHS_prepend isn't needed * ${PN}-${PV} -> ${BP} * drop autotools, it doesn't use autotools, there is just a Makefile * use SUMMARY instead of DESCRIPTION Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-devtools/debootstrap/debootstrap_1.0.67.bb26
1 files changed, 18 insertions, 8 deletions
diff --git a/meta-oe/recipes-devtools/debootstrap/debootstrap_1.0.67.bb b/meta-oe/recipes-devtools/debootstrap/debootstrap_1.0.67.bb
index 8e4a988e57..73dea9b823 100644
--- a/meta-oe/recipes-devtools/debootstrap/debootstrap_1.0.67.bb
+++ b/meta-oe/recipes-devtools/debootstrap/debootstrap_1.0.67.bb
@@ -1,12 +1,10 @@
-DESCRIPTION = "Install a Debian system into a subdirectory"
+SUMMARY = "Install a Debian system into a subdirectory"
HOMEPAGE = "https://wiki.debian.org/Debootstrap"
SECTION = "devel"
LICENSE = "debootstrap-custom-license"
LIC_FILES_CHKSUM = "file://debian/copyright;md5=1e68ced6e1689d4cd9dac75ff5225608"
-inherit autotools pkgconfig
-
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+inherit pkgconfig
SRC_URI = "\
http://http.debian.net/debian/pool/main/d/debootstrap/debootstrap_1.0.67.tar.gz \
@@ -16,9 +14,21 @@ SRC_URI = "\
SRC_URI[md5sum] = "eacabfe2e45415af60b1d74c3a23418a"
SRC_URI[sha256sum] = "0a12e0a2bbff185d47711a716b1f2734856100e8784361203e834fed0cffa51b"
-S = "${WORKDIR}/${PN}-${PV}"
+S = "${WORKDIR}/${BP}"
+
+# All Makefile does is creation of devices.tar.gz, which fails in OE build, we use
+# static devices.tar.gz as work around
+# | NOTE: make -j 8 -e MAKEFLAGS=
+# | rm -rf dev
+# | mkdir -p dev
+# | chown 0:0 dev
+# | chown: changing ownership of `dev': Operation not permitted
+# | make: *** [devices.tar.gz] Error 1
+# | WARNING: exit code 1 from a shell command.
+do_compile_prepend() {
+ cp ${WORKDIR}/devices.tar.gz ${B}
+}
-do_install_prepend() {
- cp ${WORKDIR}/devices.tar.gz ${S}
- cd "${S}"
+do_install() {
+ oe_runmake 'DESTDIR=${D}' install
}