aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan McGregor <dan.mcgregor@usask.ca>2015-10-15 14:24:15 -0600
committerDan McGregor <dan.mcgregor@usask.ca>2015-10-23 10:00:55 -0600
commit38922a504329d79aa71b46dd04030afaa68e2f27 (patch)
tree1daae31bd5481736b6649103ccbb232a0d15728d
parentabbdfd35c13c150030eee3dd644b6a469f3af211 (diff)
downloadmeta-openembedded-contrib-38922a504329d79aa71b46dd04030afaa68e2f27.tar.gz
python-html5lib: import recipe from meta-openstack
This recipe is needed for GateOne. Signed-off-by: Dan McGregor <dan.mcgregor@usask.ca>
-rw-r--r--meta-python/recipes-devtools/python/python-html5lib_0.999.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-html5lib_0.999.bb b/meta-python/recipes-devtools/python/python-html5lib_0.999.bb
new file mode 100644
index 0000000000..9ad84e8cfd
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-html5lib_0.999.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "HTML parser based on the WHATWG HTML specifcation"
+HOMEPAGE = "https://github.com/html5lib/html5lib-python"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=1ba5ada9e6fead1fdc32f43c9f10ba7c"
+
+PR = "r0"
+
+SRCNAME = "html5lib"
+SRC_URI = "http://pypi.python.org/packages/source/h/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
+
+SRC_URI[md5sum] = "acb8ba4d6db5637360a07859192eb7f8"
+SRC_URI[sha256sum] = "c3887f7e2875d7666107fa8bee761ff95b9391acdcc7cd1b5fd57a23b5fbc49e"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit setuptools
+
+# DEPENDS_default: python-pip
+
+DEPENDS += " \
+ python-pip \
+ "
+
+# RDEPENDS_default:
+RDEPENDS_${PN} += " \
+ "