aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoe MacDonald <joe_macdonald@mentor.com>2015-01-06 23:32:38 -0500
committerJoe MacDonald <joe_macdonald@mentor.com>2015-01-26 08:54:08 -0500
commit645df34e8a319c8de6a7a1f282fd7cef6004639e (patch)
tree8b2b6790c2936dcb65419f49e964ecaab8537d8c
parente18830c2b4323487f9afa5205f13579903c7f9d4 (diff)
downloadmeta-openembedded-contrib-645df34e8a319c8de6a7a1f282fd7cef6004639e.tar.gz
opensaf: update SRC_URI and install actions
The default configuration for OpenSAF creates /run and /var/lock during install time. Tweak the recipe to use ${localstatedir} as other recipes do, and clean up at the end of do_install. Swap the hard-coded SRC_URI with ${SOURCEFORGE_MIRROR} while we're at it. Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-networking/recipes-daemons/opensaf/opensaf_4.5.0.bb8
1 files changed, 5 insertions, 3 deletions
diff --git a/meta-networking/recipes-daemons/opensaf/opensaf_4.5.0.bb b/meta-networking/recipes-daemons/opensaf/opensaf_4.5.0.bb
index a58de5ce43..5b42defb38 100644
--- a/meta-networking/recipes-daemons/opensaf/opensaf_4.5.0.bb
+++ b/meta-networking/recipes-daemons/opensaf/opensaf_4.5.0.bb
@@ -13,7 +13,7 @@ HOMEPAGE = "http://www.opensaf.org"
inherit autotools useradd systemd pkgconfig
-SRC_URI = "http://jaist.dl.sourceforge.net/project/opensaf/releases/${BPN}-${PV}.tar.gz \
+SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/releases/${BPN}-${PV}.tar.gz \
file://install-samples-from-srcdir.patch"
SRC_URI[md5sum] = "534c0a99438a62c4c8dda56cfa67300c"
@@ -31,10 +31,12 @@ USERADD_PARAM_${PN} = "-r -g opensaf -d ${datadir}/opensaf/ -s ${sbindir}/nolog
SYSTEMD_SERVICE_${PN} += "opensafd.service"
SYSTEMD_AUTO_ENABLE = "disable"
-FILES_${PN} += "/run"
+FILES_${PN} += "${localstatedir}/run"
INSANE_SKIP_${PN} = "dev-so"
do_install_append() {
- rm -rf "${D}${localstatedir}/run"
+ rm -fr "${D}${localstatedir}/lock"
+ rm -fr "${D}${localstatedir}/run"
+ rmdir --ignore-fail-on-non-empty "${D}${localstatedir}"
}