aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoralperak <alperyasinak1@gmail.com>2024-03-08 08:51:36 +0300
committerKhem Raj <raj.khem@gmail.com>2024-03-08 10:07:29 -0800
commitdd0a156fa8f40ead036662d5a422d643ccfda1ed (patch)
tree6ea9ad4713951dd5c32c6e72a2cb810647cd9852
parent8a69bf4e36f0d013c88fe5a7a97356d2cdc2e191 (diff)
downloadmeta-openembedded-contrib-dd0a156fa8f40ead036662d5a422d643ccfda1ed.tar.gz
python3-google-auth: add ptest and update runtime dependencies
* Generally we want to keep images as small as possible. RDEPENDS should not contains nothing except what is absolutely needed for a recipe. * Tested on qemux86-64 and qemuarm64 * Add ptest into PTESTS_SLOW_META_PYTHON Ptest results: ============== qemux86-64: Testsuite summary TOTAL: 1074 PASS: 1074 SKIP: 0 XFAIL: 0 FAIL: 0 XPASS: 0 ERROR: 0 DURATION: 227 END: /usr/lib/python3-google-auth/ptest 2024-03-07T21:30 STOP: ptest-runner TOTAL: 1 FAIL: 0 qemuarm64: Testsuite summary TOTAL: 1074 PASS: 1074 SKIP: 0 XFAIL: 0 FAIL: 0 XPASS: 0 ERROR: 0 DURATION: 184 END: /usr/lib/python3-google-auth/ptest 2024-03-07T21:15 STOP: ptest-runner TOTAL: 1 FAIL: 0 Signed-off-by: alperak <alperyasinak1@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/conf/include/ptest-packagelists-meta-python.inc1
-rw-r--r--meta-python/recipes-devtools/python/python3-google-auth/run-ptest4
-rw-r--r--meta-python/recipes-devtools/python/python3-google-auth_2.28.1.bb43
3 files changed, 34 insertions, 14 deletions
diff --git a/meta-python/conf/include/ptest-packagelists-meta-python.inc b/meta-python/conf/include/ptest-packagelists-meta-python.inc
index ce5ccf22d5..63457189e2 100644
--- a/meta-python/conf/include/ptest-packagelists-meta-python.inc
+++ b/meta-python/conf/include/ptest-packagelists-meta-python.inc
@@ -78,6 +78,7 @@ PTESTS_FAST_META_PYTHON = "\
PTESTS_SLOW_META_PYTHON = "\
python3-arrow \
+ python3-google-auth \
python3-lz4 \
python3-marshmallow \
python3-pytest-localserver \
diff --git a/meta-python/recipes-devtools/python/python3-google-auth/run-ptest b/meta-python/recipes-devtools/python/python3-google-auth/run-ptest
new file mode 100644
index 0000000000..f1c8729f0e
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-google-auth/run-ptest
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+pytest --automake
+
diff --git a/meta-python/recipes-devtools/python/python3-google-auth_2.28.1.bb b/meta-python/recipes-devtools/python/python3-google-auth_2.28.1.bb
index 4524cca48c..1f37544d2e 100644
--- a/meta-python/recipes-devtools/python/python3-google-auth_2.28.1.bb
+++ b/meta-python/recipes-devtools/python/python3-google-auth_2.28.1.bb
@@ -3,24 +3,39 @@ HOMEPAGE = "https://github.com/googleapis/google-auth-library-python"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
-inherit pypi setuptools3
+inherit pypi setuptools3 ptest
SRC_URI[sha256sum] = "34fc3046c257cedcf1622fc4b31fc2be7923d9b4d44973d481125ecc50d83885"
-RDEPENDS:${PN} += "\
- python3-asyncio \
- python3-datetime \
- python3-io \
- python3-json \
- python3-logging \
- python3-netclient \
- python3-numbers \
+SRC_URI += " \
+ file://run-ptest \
+"
+
+RDEPENDS:${PN}-ptest += " \
+ python3-cryptography \
+ python3-flask \
+ python3-freezegun \
+ python3-grpcio \
+ python3-mock \
+ python3-oauth2client \
+ python3-pyopenssl \
+ python3-pytest \
+ python3-pytest-localserver \
+ python3-pyu2f \
+ python3-requests \
+ python3-responses \
+ python3-unittest-automake-output \
+ python3-unixadmin \
"
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/tests
+ cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
+}
+
RDEPENDS:${PN} += "\
- python3-aiohttp \
- python3-cachetools \
- python3-pyasn1-modules \
- python3-rsa \
- python3-six \
+ python3-cachetools \
+ python3-json \
+ python3-pyasn1-modules \
+ python3-rsa \
"