aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2017-09-17 11:17:31 -0700
committerArmin Kuster <akuster808@gmail.com>2017-09-17 11:17:31 -0700
commita242b1d3da32bed38fa07478840e030e17e5355e (patch)
tree0dec08fa740a1313887e728d32dff1810ff972cd
parent3bdf103f5346ae95e65f637440f43b52358e8559 (diff)
downloadmeta-openembedded-contrib-a242b1d3da32bed38fa07478840e030e17e5355e.tar.gz
tbb: fix compile issue
/ld: error: pipeline.o: requires dynamic R_X86_64_PC32 reloc against '_ZTVN3tbb8pipelineE' which may overflow at runtime; recompile with -fPIC idea taken from Master Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-support/tbb/tbb.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/tbb/tbb.bb b/meta-oe/recipes-support/tbb/tbb.bb
index d8eb1c2f30..35840fd0a3 100644
--- a/meta-oe/recipes-support/tbb/tbb.bb
+++ b/meta-oe/recipes-support/tbb/tbb.bb
@@ -37,3 +37,4 @@ do_install() {
# ...
# | make[1]: *** [concurrent_queue.o] Error 1
ARM_INSTRUCTION_SET = "arm"
+SECURITY_CFLAGS_append = " -fPIC"