aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-01-31 17:44:13 -0800
committerArmin Kuster <akuster808@gmail.com>2018-02-23 20:39:57 -0800
commitf3d01877dc173017f0609e686dd9eaadfacb1422 (patch)
treeab571e249af2283184c7b538d7c86f2ad0a9c247
parent61e3de5fead3b6a77588cb933c9c4d0c23817978 (diff)
downloadmeta-openembedded-contrib-f3d01877dc173017f0609e686dd9eaadfacb1422.tar.gz
net-snmp: Fix compiler options with paths in net-snmp-config
options which involve paths into workspace are usually filtered out with the sed command, however currently it does half the job and the resulting config file gets partial replacements leaving the compiler options with bad syntax e.g. -fdebug-prefix-map option is left with -fdebug-prefix-map= which is not correct syntax, the effect of this is seen in other recipes which then invoke net-snmp-config script and add the flags obtained from this script into its own configure scripts and then tries to execute tests, these tests fail because of bad compiler options e.g. keepalived where configure tests fails like | configure: error: *** incorrect CFLAGS from net-snmp-config this is because of wrong compiler options that it got from recipe-sysroot/usr/bin/crossscripts/net-snmp-config This patch tries to be specific about which options should be skimmed and removes the options completely Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-networking/recipes-protocols/net-snmp/net-snmp_5.7.3.bb8
1 files changed, 4 insertions, 4 deletions
diff --git a/meta-networking/recipes-protocols/net-snmp/net-snmp_5.7.3.bb b/meta-networking/recipes-protocols/net-snmp/net-snmp_5.7.3.bb
index 5a7773e084..faf73a5636 100644
--- a/meta-networking/recipes-protocols/net-snmp/net-snmp_5.7.3.bb
+++ b/meta-networking/recipes-protocols/net-snmp/net-snmp_5.7.3.bb
@@ -119,10 +119,10 @@ do_install_append() {
sed -e "s@^NSC_SRCDIR=.*@NSC_SRCDIR=.@g" \
-i ${D}${bindir}/net-snmp-create-v3-user
sed -e "s@^NSC_SRCDIR=.*@NSC_SRCDIR=.@g" \
- -e "s@${STAGING_DIR_NATIVE}[=]*@@g" \
- -e "s@${STAGING_DIR_HOST}[=]*@@g" \
- -e "s@${WORKDIR}[=]*@@g" \
- -e "s@${D}@@g" \
+ -e "s@\([^ ]*-fdebug-prefix-map=[^ ]*\)\1*@@g" \
+ -e "s@\([^ ]*--sysroot=[^ ]*\)\1*@@g" \
+ -e "s@\([^ ]*--with-libtool-sysroot=[^ ]*\)\1*@@g" \
+ -e "s@\([^ ]*--with-install-prefix=[^ ]*\)\1*@@g" \
-i ${D}${bindir}/net-snmp-config
if [ "${HAS_PERL}" = "1" ]; then