aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Bresticker <abrestic@waymo.com>2018-09-14 16:57:27 -0700
committerKhem Raj <raj.khem@gmail.com>2018-09-14 19:02:18 -0700
commitea2ee9c7acbfc23b39eb57301dd66c80b389200d (patch)
tree8e7dbea2aab017dec39bd632dcd7a664c1e81af3
parentdcd9887931a2ab10309599935ddec1256b07e942 (diff)
downloadmeta-openembedded-contrib-ea2ee9c7acbfc23b39eb57301dd66c80b389200d.tar.gz
libdevmapper: Install dmsetup
Commit 6aa1dd223a140 ("lvm2/libdevmapper: fix invoking lvcreate failed") moved installation of dmsetup back to lvm2 from libdevmapper, but dmsetup had intentionally been moved to libdevmapper in commit 269d009a81d4 ("lvm2: libdevicemapper package needs udev rules and dmsetup"). Add it back to libdevmapper by explicitly installing it in do_install(), and refresh explicitly-do-not-install-libdm.patch so that we also explicitly do not install dmsetup as part of lvm2. Signed-off-by: Andrew Bresticker <abrestic@waymo.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-support/lvm2/libdevmapper_2.02.180.bb1
-rw-r--r--meta-oe/recipes-support/lvm2/lvm2/0001-explicitly-do-not-install-libdm.patch28
2 files changed, 23 insertions, 6 deletions
diff --git a/meta-oe/recipes-support/lvm2/libdevmapper_2.02.180.bb b/meta-oe/recipes-support/lvm2/libdevmapper_2.02.180.bb
index f3f11ef647..26af3275d8 100644
--- a/meta-oe/recipes-support/lvm2/libdevmapper_2.02.180.bb
+++ b/meta-oe/recipes-support/lvm2/libdevmapper_2.02.180.bb
@@ -9,6 +9,7 @@ TARGET_CC_ARCH += "${LDFLAGS}"
do_install() {
oe_runmake 'DESTDIR=${D}' -C libdm install
+ oe_runmake 'DESTDIR=${D}' -C tools install_device-mapper
}
RRECOMMENDS_${PN}_append_class-target = " lvm2-udevrules"
diff --git a/meta-oe/recipes-support/lvm2/lvm2/0001-explicitly-do-not-install-libdm.patch b/meta-oe/recipes-support/lvm2/lvm2/0001-explicitly-do-not-install-libdm.patch
index e85818dbd4..7f5dd93341 100644
--- a/meta-oe/recipes-support/lvm2/lvm2/0001-explicitly-do-not-install-libdm.patch
+++ b/meta-oe/recipes-support/lvm2/lvm2/0001-explicitly-do-not-install-libdm.patch
@@ -1,4 +1,4 @@
-From 0a8e466fcf99622896e070c5133165e4278e8cfb Mon Sep 17 00:00:00 2001
+From 5a3e13ae94318c2bed60f875bb3852c45ce0113c Mon Sep 17 00:00:00 2001
From: Hongxu Jia <hongxu.jia@windriver.com>
Date: Thu, 25 May 2017 05:27:11 -0400
Subject: [PATCH] explicitly do not install libdm
@@ -9,12 +9,14 @@ explicitly do not do the installation here.
Upstream-Status: Inappropriate [meta-oe specific]
Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
+Signed-off-by: Andrew Bresticker <abrestic@waymo.com>
---
libdm/Makefile.in | 6 ++++--
- 1 file changed, 4 insertions(+), 2 deletions(-)
+ tools/Makefile.in | 3 ++-
+ 2 files changed, 6 insertions(+), 3 deletions(-)
diff --git a/libdm/Makefile.in b/libdm/Makefile.in
-index 3c9a4ce..45c91c6 100644
+index 66ec39513..c779c9d86 100644
--- a/libdm/Makefile.in
+++ b/libdm/Makefile.in
@@ -77,9 +77,11 @@ ifeq ("@PKGCONFIG@", "yes")
@@ -23,14 +25,28 @@ index 3c9a4ce..45c91c6 100644
-install: $(INSTALL_TYPE) install_include
+install:
-+ echo "Do not install device mappler in lvm2"
++ echo "Do not install device mapper in lvm2"
-install_device-mapper: install
+install_device-mapper:
-+ echo "Do not install device mappler in lvm2"
++ echo "Do not install device mapper in lvm2"
install_include: $(srcdir)/libdevmapper.h
$(INSTALL_DATA) -D $< $(includedir)/$(<F)
+diff --git a/tools/Makefile.in b/tools/Makefile.in
+index 103b76732..63ba7fc04 100644
+--- a/tools/Makefile.in
++++ b/tools/Makefile.in
+@@ -267,7 +267,8 @@ install_dmsetup_static: dmsetup.static
+ $(Q) $(INSTALL_PROGRAM) -D $< $(staticdir)/$(<F)
+ $(Q) $(LN_S) -f $(<F) $(staticdir)/dmstats
+
+-install_device-mapper: $(INSTALL_DMSETUP_TARGETS)
++install_device-mapper:
++ echo "Do not install device mapper in lvm2"
+
+ install_lvm2: $(INSTALL_LVM_TARGETS)
+
--
-2.8.1
+2.19.0.397.gdd90340f6a-goog