aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-12-17 17:33:42 -0800
committerKhem Raj <raj.khem@gmail.com>2018-12-18 22:15:59 -0800
commitba604d99ae80b3e0fb908f4de8f1ac9008b7336f (patch)
tree4c981d6538a1a916ef705e87bb90ff7042b45eff
parent2dc1b2411c7e43475416e79959c1344797516158 (diff)
downloadmeta-openembedded-contrib-ba604d99ae80b3e0fb908f4de8f1ac9008b7336f.tar.gz
catch2: Upgrade to 2.5.0 release
Drop upstreamed patch and add a patch to fix build seen with clang and gcc9 Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-test/catch2/catch2/0001-Fix-convert-from-char-on-ARM-build.patch46
-rw-r--r--meta-oe/recipes-test/catch2/catch2/0001-Remove-redundant-move.patch36
-rw-r--r--meta-oe/recipes-test/catch2/catch2_2.5.0.bb (renamed from meta-oe/recipes-test/catch2/catch2_2.4.1.bb)16
3 files changed, 45 insertions, 53 deletions
diff --git a/meta-oe/recipes-test/catch2/catch2/0001-Fix-convert-from-char-on-ARM-build.patch b/meta-oe/recipes-test/catch2/catch2/0001-Fix-convert-from-char-on-ARM-build.patch
deleted file mode 100644
index 3073775630..0000000000
--- a/meta-oe/recipes-test/catch2/catch2/0001-Fix-convert-from-char-on-ARM-build.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-From 5729874fa5059c39aa97cfa08fddf107b7a65c9e Mon Sep 17 00:00:00 2001
-From: Miguel Gaio <mgaio35@gmail.com>
-Date: Wed, 3 Oct 2018 10:22:16 +0200
-Subject: [PATCH] Fix convert from char on ARM build
-
-Some platforms set the signedness of char to unsigned (eg. ARM).
-Convert from char should not assume the signedness of char.
-
-Fix build issue with -Werror,-Wtautological-unsigned-zero-compare flags.
-
-Signed-off-by: Miguel Gaio <mgaio35@gmail.com>
-
-Upstream-Status: Accepted [Commit f1faaa9c107113692301ad8bb56084460ef1a2ff]
-
-Signed-off-by: Bartosz Golaszewski <bgolaszewski@baylibre.com>
----
- include/internal/catch_tostring.cpp | 6 +++---
- 1 file changed, 3 insertions(+), 3 deletions(-)
-
-diff --git a/include/internal/catch_tostring.cpp b/include/internal/catch_tostring.cpp
-index 4e0c027d..8cbabbf2 100644
---- a/include/internal/catch_tostring.cpp
-+++ b/include/internal/catch_tostring.cpp
-@@ -205,7 +205,7 @@ std::string StringMaker<bool>::convert(bool b) {
- return b ? "true" : "false";
- }
-
--std::string StringMaker<char>::convert(char value) {
-+std::string StringMaker<signed char>::convert(signed char value) {
- if (value == '\r') {
- return "'\\r'";
- } else if (value == '\f') {
-@@ -222,8 +222,8 @@ std::string StringMaker<char>::convert(char value) {
- return chstr;
- }
- }
--std::string StringMaker<signed char>::convert(signed char c) {
-- return ::Catch::Detail::stringify(static_cast<char>(c));
-+std::string StringMaker<char>::convert(char c) {
-+ return ::Catch::Detail::stringify(static_cast<signed char>(c));
- }
- std::string StringMaker<unsigned char>::convert(unsigned char c) {
- return ::Catch::Detail::stringify(static_cast<char>(c));
---
-2.19.1
-
diff --git a/meta-oe/recipes-test/catch2/catch2/0001-Remove-redundant-move.patch b/meta-oe/recipes-test/catch2/catch2/0001-Remove-redundant-move.patch
new file mode 100644
index 0000000000..c3f5fc9ce7
--- /dev/null
+++ b/meta-oe/recipes-test/catch2/catch2/0001-Remove-redundant-move.patch
@@ -0,0 +1,36 @@
+From b2bd82a0c0d3d5dda588d12cc1672a03a9630784 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Mon, 17 Dec 2018 17:27:43 -0800
+Subject: [PATCH] Remove redundant move
+
+fixes errors like below
+
+/mnt/a/yoe/build/tmp/work/aarch64-yoe-linux-musl/catch2/2.5.0-r0/git/include/internal/catch_session.cpp:52:29:
+error: redundant move in return statement [-Werror=redundant-move]
+ 52 | return std::move(multi);
+ | ~~~~~~~~~^~~~~~~
+/mnt/a/yoe/build/tmp/work/aarch64-yoe-linux-musl/catch2/2.5.0-r0/git/include/internal/catch_session.cpp:52:29:
+note: remove 'std::move' call
+
+Upstream-Status: Submitted [https://github.com/catchorg/Catch2/pull/1474]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ include/internal/catch_session.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/include/internal/catch_session.cpp b/include/internal/catch_session.cpp
+index 0920521c..b66d57ac 100644
+--- a/include/internal/catch_session.cpp
++++ b/include/internal/catch_session.cpp
+@@ -49,7 +49,7 @@ namespace Catch {
+ multi->addListener(listener->create(Catch::ReporterConfig(config)));
+ }
+ multi->addReporter(createReporter(config->getReporterName(), config));
+- return std::move(multi);
++ return multi;
+ }
+
+
+--
+2.20.1
+
diff --git a/meta-oe/recipes-test/catch2/catch2_2.4.1.bb b/meta-oe/recipes-test/catch2/catch2_2.5.0.bb
index 0183c2e41a..14a1ebe80d 100644
--- a/meta-oe/recipes-test/catch2/catch2_2.4.1.bb
+++ b/meta-oe/recipes-test/catch2/catch2_2.5.0.bb
@@ -6,19 +6,21 @@ LICENSE = "BSL-1.0"
LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e4224ccaecb14d942c71d31bef20d78c"
SRC_URI = "git://github.com/catchorg/Catch2.git \
- file://0001-Fix-convert-from-char-on-ARM-build.patch"
-SRCREV = "9e1bdca4667295fcb16265eae00efa8423f07007"
+ file://0001-Remove-redundant-move.patch \
+ "
+# v2.5.0
+SRCREV = "6ccd467094973824d89efb16cbc553e279f79823"
S = "${WORKDIR}/git"
inherit cmake python3native
+do_install_append() {
+ rm ${D}${datadir}/Catch2/lldbinit
+ rm ${D}${datadir}/Catch2/gdbinit
+ rmdir ${D}${datadir}/Catch2/
+}
# Header-only library
RDEPENDS_${PN}-dev = ""
RRECOMMENDS_${PN}-dbg = "${PN}-dev (= ${EXTENDPKGV})"
-do_install_append() {
- rm ${D}/${datadir}/Catch2/lldbinit
- rm ${D}/${datadir}/Catch2/gdbinit
- rmdir ${D}/${datadir}/Catch2/
-}