aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMax Kellermann <max.kellermann@gmail.com>2018-10-05 19:01:08 +0200
committerKhem Raj <raj.khem@gmail.com>2018-10-05 14:51:14 -0700
commitba24cbde104afa582b0d33edfef331567df60e11 (patch)
tree97b376a53fa6790851b6bcd7b9a052e229bdeb05
parent592f37ede22f8dd03321353d75c55a015656743a (diff)
downloadmeta-openembedded-contrib-ba24cbde104afa582b0d33edfef331567df60e11.tar.gz
ncmpc: add various PACKAGECONFIGs
Signed-off-by: Max Kellermann <max.kellermann@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-multimedia/recipes-multimedia/musicpd/ncmpc_0.32.bb19
1 files changed, 18 insertions, 1 deletions
diff --git a/meta-multimedia/recipes-multimedia/musicpd/ncmpc_0.32.bb b/meta-multimedia/recipes-multimedia/musicpd/ncmpc_0.32.bb
index bc77644244..62885bba10 100644
--- a/meta-multimedia/recipes-multimedia/musicpd/ncmpc_0.32.bb
+++ b/meta-multimedia/recipes-multimedia/musicpd/ncmpc_0.32.bb
@@ -6,13 +6,30 @@ HOMEPAGE = "https://www.musicpd.org/clients/ncmpc/"
inherit meson
DEPENDS += " \
- gettext-native \
boost \
pcre \
ncurses \
libmpdclient \
"
+PACKAGECONFIG ??= "colors locale mouse nls help_screen artist_screen search_screen song_screen key_screen lyrics_screen outputs_screen"
+
+PACKAGECONFIG[colors] = "-Dcolors=true,-Dcolors=false"
+PACKAGECONFIG[lirc] = "-Dlirc=true,-Dlirc=false,lirc"
+PACKAGECONFIG[locale] = "-Dlocale=true,-Dlocale=false"
+PACKAGECONFIG[mini] = "-Dmini=true,-Dmini=false"
+PACKAGECONFIG[mouse] = "-Dmouse=true,-Dmouse=false"
+PACKAGECONFIG[nls] = "-Dnls=true,-Dnls=false,gettext-native"
+
+PACKAGECONFIG[help_screen] = "-Dhelp_screen=true,-Dhelp_screen=false"
+PACKAGECONFIG[artist_screen] = "-Dartist_screen=true,-Dartist_screen=false"
+PACKAGECONFIG[search_screen] = "-Dsearch_screen=true,-Dsearch_screen=false"
+PACKAGECONFIG[song_screen] = "-Dsong_screen=true,-Dsong_screen=false"
+PACKAGECONFIG[key_screen] = "-Dkey_screen=true,-Dkey_screen=false"
+PACKAGECONFIG[lyrics_screen] = "-Dlyrics_screen=true,-Dlyrics_screen=false"
+PACKAGECONFIG[outputs_screen] = "-Doutputs_screen=true,-Doutputs_screen=false"
+PACKAGECONFIG[chat_screen] = "-Dchat_screen=true,-Dchat_screen=false"
+
SRC_URI = " \
git://github.com/MusicPlayerDaemon/ncmpc \
"