aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Joseph <tomjoseph83@gmail.com>2018-09-04 16:35:27 +0530
committerKhem Raj <raj.khem@gmail.com>2018-09-04 11:55:21 -0700
commita09e43e371261a50ee93a3d97eeac38cce3bfd88 (patch)
treedc90b9f4aa022cd84e7e649f27f158485d4c9d70
parent91842a1bc8e4eb60e54529943c3bde629e7b0cc1 (diff)
downloadmeta-openembedded-contrib-a09e43e371261a50ee93a3d97eeac38cce3bfd88.tar.gz
PAM: Add python library pamela which supports PAM
Pamela is a python wrapper for PAM. Compared to python-pam it has wrapper for account management apis in addition to authentication apis. Signed-off-by: Tom Joseph <tomjoseph83@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/pamela_0.3.0.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/pamela_0.3.0.bb b/meta-python/recipes-devtools/python/pamela_0.3.0.bb
new file mode 100644
index 0000000000..8071fcb04f
--- /dev/null
+++ b/meta-python/recipes-devtools/python/pamela_0.3.0.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "Pamela: yet another Python wrapper for PAM"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://PKG-INFO;md5=bfb663f37eb99232bc8ccfa4ea8f1202"
+
+SRC_URI[md5sum] = "de6516118d51eb5fc97017f3b6d5c68b"
+SRC_URI[sha256sum] = "1e198446a6cdd87704aa0def7621d62e7c20b0e6068e2788b9a866a8355e5d6b"
+
+PYPI_PACKAGE = "pamela"
+
+inherit pypi setuptools
+
+RDEPENDS_${PN} = "libpam"
+
+inherit distro_features_check
+REQUIRED_DISTRO_FEATURES = "pam"