aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2018-12-18 15:38:42 +0800
committerKhem Raj <raj.khem@gmail.com>2018-12-18 18:44:59 -0800
commit9ff2a0bf6f1889a22524847dfe2e61b24ed0e29c (patch)
tree6bd3560e5fd779c85e9f682037065767f4c5d7a1
parent5dafdbc58ed5ff0d9fb93253477d44fc4bb811ae (diff)
downloadmeta-openembedded-contrib-9ff2a0bf6f1889a22524847dfe2e61b24ed0e29c.tar.gz
efibootmgr: fix conflicting types for 'efi_set_verbose'
Since upstream efivar-37 pulibc efi_set_verbose in its headers [daf3b6c Move verbosity headers to be public], it is not necessary to delcare in efibootmgr. Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-bsp/efibootmgr/efibootmgr_17.bb1
-rw-r--r--meta-oe/recipes-bsp/efibootmgr/files/0001-remove-extra-decl.patch31
2 files changed, 32 insertions, 0 deletions
diff --git a/meta-oe/recipes-bsp/efibootmgr/efibootmgr_17.bb b/meta-oe/recipes-bsp/efibootmgr/efibootmgr_17.bb
index 8fdfedb830..4edb2e6644 100644
--- a/meta-oe/recipes-bsp/efibootmgr/efibootmgr_17.bb
+++ b/meta-oe/recipes-bsp/efibootmgr/efibootmgr_17.bb
@@ -12,6 +12,7 @@ COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux"
SRCREV = "e067160ecef8208e1944002e5d50b275733211fb"
SRC_URI = "git://github.com/rhinstaller/efibootmgr.git;protocol=https \
+ file://0001-remove-extra-decl.patch \
"
S = "${WORKDIR}/git"
diff --git a/meta-oe/recipes-bsp/efibootmgr/files/0001-remove-extra-decl.patch b/meta-oe/recipes-bsp/efibootmgr/files/0001-remove-extra-decl.patch
new file mode 100644
index 0000000000..42f3a8182d
--- /dev/null
+++ b/meta-oe/recipes-bsp/efibootmgr/files/0001-remove-extra-decl.patch
@@ -0,0 +1,31 @@
+From 99b578501643377e0b1994b2a068b790d189d5ad Mon Sep 17 00:00:00 2001
+From: Peter Jones <pjones@redhat.com>
+Date: Wed, 13 Jun 2018 09:41:01 -0400
+Subject: [PATCH] remove extra decl
+
+Signed-off-by: Peter Jones <pjones@redhat.com>
+
+Upstream-Status: Backport [git://github.com/rhinstaller/efibootmgr.git]
+Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
+
+---
+ src/efibootmgr.c | 3 ---
+ 1 file changed, 3 deletions(-)
+
+diff --git a/src/efibootmgr.c b/src/efibootmgr.c
+index de38f01..4e1a680 100644
+--- a/src/efibootmgr.c
++++ b/src/efibootmgr.c
+@@ -1536,9 +1536,6 @@ parse_opts(int argc, char **argv)
+ "invalid numeric value %s\n",
+ optarg);
+ }
+- /* XXX efivar-36 accidentally doesn't have a public
+- * header for this */
+- extern int efi_set_verbose(int verbosity, FILE *errlog);
+ efi_set_verbose(opts.verbose - 2, stderr);
+ break;
+ case 'V':
+--
+2.7.4
+