aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2018-09-03 11:32:15 +1200
committerKhem Raj <raj.khem@gmail.com>2018-09-04 11:55:21 -0700
commit9c0243b69180741ef722fd03d4291c3f31fad9e2 (patch)
treec482ff1b1f73d5da979a4d29ebad843ae308f3bd
parent35952eda3f73ad2937b1ee3243b1e189d6def1f6 (diff)
downloadmeta-openembedded-contrib-9c0243b69180741ef722fd03d4291c3f31fad9e2.tar.gz
mosquitto: upgrade to 1.5.1
This includes one security fix and numerous other bugfixes. MQTT version 3.1.1 is now the default protocol. See the following for details: https://mosquitto.org/blog/2018/08/version-151-released/ https://mosquitto.org/blog/2018/05/version-1-5-released/ Changes to the recipe: * Drop explicit installation of the libmosquitto.a static library because this no longer gets built by default, and the normal "make install" which we are running will install it anyway if it were to be enabled. * Drop our service file since there is one supplied in the source tree * Enable systemd notify support when systemd is being used * Update comments in the init script Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-networking/recipes-connectivity/mosquitto/files/mosquitto.init4
-rw-r--r--meta-networking/recipes-connectivity/mosquitto/files/mosquitto.service15
-rw-r--r--meta-networking/recipes-connectivity/mosquitto/mosquitto_1.5.1.bb (renamed from meta-networking/recipes-connectivity/mosquitto/mosquitto_1.4.15.bb)11
3 files changed, 6 insertions, 24 deletions
diff --git a/meta-networking/recipes-connectivity/mosquitto/files/mosquitto.init b/meta-networking/recipes-connectivity/mosquitto/files/mosquitto.init
index d2a27b2732..6a0c12760e 100644
--- a/meta-networking/recipes-connectivity/mosquitto/files/mosquitto.init
+++ b/meta-networking/recipes-connectivity/mosquitto/files/mosquitto.init
@@ -8,9 +8,9 @@
# Required-Stop: $remote_fs $syslog
# Default-Start: 2 3 4 5
# Default-Stop: 0 1 6
-# Short-Description: mosquitto MQTT v3.1 message broker
+# Short-Description: mosquitto MQTT message broker
# Description:
-# This is a message broker that supports version 3.1 of the MQ Telemetry
+# This is a message broker that supports version 3.1/3.1.1 of the MQ Telemetry
# Transport (MQTT) protocol.
#
# MQTT provides a method of carrying out messaging using a publish/subscribe
diff --git a/meta-networking/recipes-connectivity/mosquitto/files/mosquitto.service b/meta-networking/recipes-connectivity/mosquitto/files/mosquitto.service
deleted file mode 100644
index 25f68fae05..0000000000
--- a/meta-networking/recipes-connectivity/mosquitto/files/mosquitto.service
+++ /dev/null
@@ -1,15 +0,0 @@
-[Unit]
-Description=Mosquitto - lightweight server implementation of the MQTT and MQTT-SN protocols
-ConditionPathExists=/etc/mosquitto/mosquitto.conf
-After=network.target
-
-[Service]
-Type=simple
-ExecStartPre=/bin/rm -f /var/run/mosquitto.pid
-ExecStart=/usr/sbin/mosquitto -c /etc/mosquitto/mosquitto.conf
-ExecReload=/bin/kill -HUP $MAINPID
-PIDFile=/var/run/mosquitto.pid
-Restart=on-failure
-
-[Install]
-WantedBy=multi-user.target
diff --git a/meta-networking/recipes-connectivity/mosquitto/mosquitto_1.4.15.bb b/meta-networking/recipes-connectivity/mosquitto/mosquitto_1.5.1.bb
index f451687a68..fa51f4e76e 100644
--- a/meta-networking/recipes-connectivity/mosquitto/mosquitto_1.4.15.bb
+++ b/meta-networking/recipes-connectivity/mosquitto/mosquitto_1.5.1.bb
@@ -12,12 +12,11 @@ DEPENDS = "uthash"
SRC_URI = "http://mosquitto.org/files/source/mosquitto-${PV}.tar.gz \
file://0002-uthash-remove-in-tree-version.patch \
- file://mosquitto.service \
file://mosquitto.init \
"
-SRC_URI[md5sum] = "546cb1ce35cc3f7d23e6d2f1f9a962e7"
-SRC_URI[sha256sum] = "7d3b3e245a3b4ec94b05678c8199c806359737949f4cfe0bf936184f6ca89a83"
+SRC_URI[md5sum] = "f98c99998a36a234f3a9d9b402b991db"
+SRC_URI[sha256sum] = "8557bc7ae34dfaf32a0fb56d2491b7a7f731269c88337227233013502df4d5b0"
inherit systemd update-rc.d useradd
@@ -34,6 +33,7 @@ EXTRA_OEMAKE = " \
${@bb.utils.contains('PACKAGECONFIG', 'dns-srv', 'WITH_SRV=yes', 'WITH_SRV=no', d)} \
${@bb.utils.contains('PACKAGECONFIG', 'ssl', 'WITH_TLS=yes WITH_TLS_PSK=yes', 'WITH_TLS=no WITH_TLS_PSK=no', d)} \
${@bb.utils.contains('PACKAGECONFIG', 'uuid', 'WITH_UUID=yes', 'WITH_UUID=no', d)} \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'WITH_SYSTEMD=yes', 'WITH_SYSTEMD=no', d)} \
STRIP=/bin/true \
WITH_DOCS=no \
"
@@ -43,11 +43,8 @@ export LIB_SUFFIX = "${@d.getVar('baselib', True).replace('lib', '')}"
do_install() {
oe_runmake 'DESTDIR=${D}' install
- install -d ${D}${libdir}
- install -m 0644 lib/libmosquitto.a ${D}${libdir}/
-
install -d ${D}${systemd_unitdir}/system/
- install -m 0644 ${WORKDIR}/mosquitto.service ${D}${systemd_unitdir}/system/
+ install -m 0644 ${S}/service/systemd/mosquitto.service.notify ${D}${systemd_unitdir}/system/mosquitto.service
install -d ${D}${sysconfdir}/mosquitto
install -m 0644 ${D}${sysconfdir}/mosquitto/mosquitto.conf.example \