aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndreas Oberritter <obi@opendreambox.org>2016-12-23 01:04:35 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2017-01-19 09:26:15 +0100
commit9beb04e98d9a6b2dfe95966e2768f886b4092e27 (patch)
treecce324f66669a11d26f729facb486162b828916b
parentcc32689a5b55843eeaecda173933fd5f281ec3ff (diff)
downloadmeta-openembedded-contrib-9beb04e98d9a6b2dfe95966e2768f886b4092e27.tar.gz
waf-samba.bbclass: fix build error with PARALLEL_MAKE="-j X -l Y"
Waf doesn't handle -l. Use a function already provided by waf.bbclass in OE-Core. Inheriting waf.bbclass also makes overriding DISABLE_STATIC redundant, so drop it from recipes inheriting waf-samba. Signed-off-by: Andreas Oberritter <obi@opendreambox.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-networking/classes/waf-samba.bbclass4
-rw-r--r--meta-networking/recipes-connectivity/samba/samba_4.4.5.bb1
-rw-r--r--meta-networking/recipes-support/libldb/libldb_1.1.29.bb1
-rw-r--r--meta-networking/recipes-support/libtalloc/libtalloc_2.1.8.bb1
-rw-r--r--meta-networking/recipes-support/libtdb/libtdb_1.3.12.bb1
-rw-r--r--meta-networking/recipes-support/libtevent/libtevent_0.9.31.bb1
6 files changed, 2 insertions, 7 deletions
diff --git a/meta-networking/classes/waf-samba.bbclass b/meta-networking/classes/waf-samba.bbclass
index af4c7d0bee..b94ed4853d 100644
--- a/meta-networking/classes/waf-samba.bbclass
+++ b/meta-networking/classes/waf-samba.bbclass
@@ -1,7 +1,7 @@
# waf is a build system which is used by samba related project.
# Obtain details from https://wiki.samba.org/index.php/Waf
#
-inherit qemu pythonnative
+inherit qemu pythonnative waf
DEPENDS += "qemu-native libxslt-native docbook-xsl-stylesheets-native python"
@@ -86,7 +86,7 @@ do_configure() {
}
do_compile () {
- python ./buildtools/bin/waf ${PARALLEL_MAKE}
+ python ./buildtools/bin/waf ${@get_waf_parallel_make(d)}
}
do_install() {
diff --git a/meta-networking/recipes-connectivity/samba/samba_4.4.5.bb b/meta-networking/recipes-connectivity/samba/samba_4.4.5.bb
index a199018c90..0ba59c7d3c 100644
--- a/meta-networking/recipes-connectivity/samba/samba_4.4.5.bb
+++ b/meta-networking/recipes-connectivity/samba/samba_4.4.5.bb
@@ -94,7 +94,6 @@ EXTRA_OECONF += "--enable-fhs \
--with-libiconv=${STAGING_DIR_HOST}${prefix} \
--with-pam --with-pammodulesdir=${base_libdir}/security \
"
-DISABLE_STATIC = ""
LDFLAGS += "-Wl,-z,relro,-z,now ${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}"
diff --git a/meta-networking/recipes-support/libldb/libldb_1.1.29.bb b/meta-networking/recipes-support/libldb/libldb_1.1.29.bb
index 378bb89309..2269a5726d 100644
--- a/meta-networking/recipes-support/libldb/libldb_1.1.29.bb
+++ b/meta-networking/recipes-support/libldb/libldb_1.1.29.bb
@@ -44,7 +44,6 @@ EXTRA_OECONF += "--disable-rpath \
--with-privatelibdir=${libdir}/ldb \
--with-libiconv=${STAGING_DIR_HOST}${prefix}\
"
-DISABLE_STATIC = ""
PACKAGES += "pyldb pyldb-dbg pyldb-dev"
diff --git a/meta-networking/recipes-support/libtalloc/libtalloc_2.1.8.bb b/meta-networking/recipes-support/libtalloc/libtalloc_2.1.8.bb
index 97a9a758b7..04e2f364dc 100644
--- a/meta-networking/recipes-support/libtalloc/libtalloc_2.1.8.bb
+++ b/meta-networking/recipes-support/libtalloc/libtalloc_2.1.8.bb
@@ -37,7 +37,6 @@ EXTRA_OECONF += "--disable-rpath \
--disable-silent-rules \
--with-libiconv=${STAGING_DIR_HOST}${prefix}\
"
-DISABLE_STATIC = ""
PACKAGES += "pytalloc pytalloc-dbg pytalloc-dev"
diff --git a/meta-networking/recipes-support/libtdb/libtdb_1.3.12.bb b/meta-networking/recipes-support/libtdb/libtdb_1.3.12.bb
index 86f931ce95..3296bee531 100644
--- a/meta-networking/recipes-support/libtdb/libtdb_1.3.12.bb
+++ b/meta-networking/recipes-support/libtdb/libtdb_1.3.12.bb
@@ -33,7 +33,6 @@ EXTRA_OECONF += "--disable-rpath \
--builtin-libraries=replace \
--with-libiconv=${STAGING_DIR_HOST}${prefix}\
"
-DISABLE_STATIC = ""
PACKAGES += "tdb-tools python-tdb python-tdb-dbg"
diff --git a/meta-networking/recipes-support/libtevent/libtevent_0.9.31.bb b/meta-networking/recipes-support/libtevent/libtevent_0.9.31.bb
index 975f8f689a..7939e03615 100644
--- a/meta-networking/recipes-support/libtevent/libtevent_0.9.31.bb
+++ b/meta-networking/recipes-support/libtevent/libtevent_0.9.31.bb
@@ -37,7 +37,6 @@ EXTRA_OECONF += "--disable-rpath \
--with-libiconv=${STAGING_DIR_HOST}${prefix}\
--without-gettext \
"
-DISABLE_STATIC = ""
PACKAGES += "python-tevent python-tevent-dbg"