aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMax Kellermann <max.kellermann@gmail.com>2018-09-18 10:26:07 +0200
committerKhem Raj <raj.khem@gmail.com>2018-09-24 11:49:45 -0700
commit6cc057dad7e8223f5258a30eeaa3fbc587dcb0a9 (patch)
tree2d62107531bc203c08a22ff2d2a89cded870f552
parentf01911ba4d184e7bcd3ff2605f243358d8f85fcf (diff)
downloadmeta-openembedded-contrib-6cc057dad7e8223f5258a30eeaa3fbc587dcb0a9.tar.gz
libblockdev: make various features optional
Signed-off-by: Max Kellermann <max.kellermann@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-extended/libblockdev/libblockdev_2.18.bb14
1 files changed, 7 insertions, 7 deletions
diff --git a/meta-oe/recipes-extended/libblockdev/libblockdev_2.18.bb b/meta-oe/recipes-extended/libblockdev/libblockdev_2.18.bb
index bf33b968e2..021f641425 100644
--- a/meta-oe/recipes-extended/libblockdev/libblockdev_2.18.bb
+++ b/meta-oe/recipes-extended/libblockdev/libblockdev_2.18.bb
@@ -10,12 +10,6 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=c07cb499d259452f324bb90c3067d85c"
inherit autotools python3native gobject-introspection
-DEPENDS += " \
- cryptsetup \
- libbytesize \
- btrfs-tools \
-"
-
SRCREV = "0debeb45562ac3d8f6f43f6f942b238abab55be9"
SRC_URI = " \
git://github.com/rhinstaller/libblockdev;branch=master \
@@ -25,7 +19,7 @@ S = "${WORKDIR}/git"
FILES_${PN} += "${PYTHON_SITEPACKAGES_DIR}"
-PACKAGECONFIG ??= "python3 lvm dm kmod parted fs escrow"
+PACKAGECONFIG ??= "python3 lvm dm kmod parted fs escrow btrfs crypto mdraid kbd lvm-dbus"
PACKAGECONFIG[python3] = "--with-python3, --without-python3,,python3"
PACKAGECONFIG[python2] = "--with-python2, --without-python2,,python2"
PACKAGECONFIG[lvm] = "--with-lvm, --without-lvm, multipath-tools, lvm2"
@@ -39,6 +33,12 @@ PACKAGECONFIG[doc] = "--with-gtk-doc, --without-gtk-doc, gtk-doc-native"
PACKAGECONFIG[nvdimm] = "--with-nvdimm, --without-nvdimm"
PACKAGECONFIG[vdo] = "--with-vdo, --without-vdo"
PACKAGECONFIG[escrow] = "--with-escrow, --without-escrow, nss volume-key"
+PACKAGECONFIG[btrfs] = "--with-btrfs,--without-btrfs,libbytesize btrfs-tools"
+PACKAGECONFIG[crypto] = "--with-crypto,--without-crypto,cryptsetup nss volume-key"
+PACKAGECONFIG[mdraid] = "--with-mdraid,--without-mdraid,libbytesize"
+PACKAGECONFIG[kbd] = "--with-kbd,--without-kbd,libbytesize"
+PACKAGECONFIG[lvm-dbus] = "--with-lvm_dbus,--without-lvm_dbus"
+PACKAGECONFIG[mpath] = "--with-mpath,--without-mpath"
export GIR_EXTRA_LIBS_PATH="${B}/src/utils/.libs"