aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKinsella, Ray <ray.kinsella@intel.com>2016-05-06 14:49:19 +0100
committerArmin Kuster <akuster808@gmail.com>2016-05-13 23:01:45 -0700
commitf797b791efdb656704262f9c46b7c9adae911faa (patch)
tree35c643c83d100ee7ebed3c499f375ac16bf1a648
parent84f69f338c3ccd351d24db7e99716d7c1db1c65d (diff)
downloadmeta-openembedded-contrib-f797b791efdb656704262f9c46b7c9adae911faa.tar.gz
wvstreams: fixing segfault with new gcc optimizations
Recent GCC optimizations -ftree-dce and -foptimize-sibling-calls are causing a segfault in the wvstream stackmaster. Fedora had the same problem and resolved the issue by removing these optimizations. See: https://bugzilla.redhat.com/show_bug.cgi?id=812651 Signed-off-by: Ray Kinsella <ray.kinsella@intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-connectivity/wvdial/wvstreams_4.6.1.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/wvdial/wvstreams_4.6.1.bb b/meta-oe/recipes-connectivity/wvdial/wvstreams_4.6.1.bb
index 73cfb03565..6199a2f7ec 100644
--- a/meta-oe/recipes-connectivity/wvdial/wvstreams_4.6.1.bb
+++ b/meta-oe/recipes-connectivity/wvdial/wvstreams_4.6.1.bb
@@ -20,6 +20,8 @@ inherit autotools-brokensep pkgconfig
PARALLEL_MAKE = ""
+TARGET_CFLAGS_append = " -fno-tree-dce -fno-optimize-sibling-calls"
+
LDFLAGS_append = " -Wl,-rpath-link,${CROSS_DIR}/${TARGET_SYS}/lib"
EXTRA_OECONF = " --without-tcl --without-qt --without-pam --without-valgrind"