aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorS. Lockwood-Childs <sjl@vctlabs.com>2016-05-27 17:54:57 -0700
committerArmin Kuster <akuster808@gmail.com>2016-08-16 10:29:39 -0700
commit94425033d9c0c16f877455dd75f78939e7c10b66 (patch)
treee774560da80b39822851bf79e8234c5994d6c2af
parent65f0a4da9e1cade91846c960eb83b0afb7de9499 (diff)
downloadmeta-openembedded-contrib-94425033d9c0c16f877455dd75f78939e7c10b66.tar.gz
cifs-utils: make samba conditional dependency
Add PACKAGECONFIG for cifsacl and update PACKAGECONFIG for cifsidmap to make samba a conditional dependency. It is nice to be able to get mount.cifs without needing to build samba. Signed-off-by: S. Lockwood-Childs <sjl@vctlabs.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com> (cherry picked from commit a6a36710a110d381b798b445b2da9d6c490215f3) Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-networking/recipes-support/cifs/cifs-utils_git.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-networking/recipes-support/cifs/cifs-utils_git.bb b/meta-networking/recipes-support/cifs/cifs-utils_git.bb
index 87306a6f28..099d885c90 100644
--- a/meta-networking/recipes-support/cifs/cifs-utils_git.bb
+++ b/meta-networking/recipes-support/cifs/cifs-utils_git.bb
@@ -4,7 +4,6 @@ SECTION = "otherosfs"
LICENSE = "GPLv3 & LGPLv3"
LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
-DEPENDS = "samba"
PV = "6.4"
SRCREV = "487f46da737291877867cbd3acb40fea087d3863"
@@ -18,7 +17,8 @@ PACKAGECONFIG[cap] = "--with-libcap,--without-libcap,libcap"
PACKAGECONFIG[cifscreds] = "--enable-cifscreds,--disable-cifscreds,keyutils"
# when enabled, it creates ${sbindir}/cifs.upcall and --ignore-fail-on-non-empty in do_install_append is needed
PACKAGECONFIG[cifsupcall] = "--enable-cifsupcall,--disable-cifsupcall,krb5 libtalloc keyutils"
-PACKAGECONFIG[cifsidmap] = "--enable-cifsidmap,--disable-cifsidmap, keyutils"
+PACKAGECONFIG[cifsidmap] = "--enable-cifsidmap,--disable-cifsidmap,keyutils samba"
+PACKAGECONFIG[cifsacl] = "--enable-cifsacl,--disable-cifsacl,samba"
PACKAGECONFIG[pam] = "--enable-pam --with-pamdir=${base_libdir}/security,--disable-pam,libpam keyutils"
inherit autotools pkgconfig