aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorArmin Kuster <akuster@mvista.com>2016-05-31 07:08:25 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2016-05-31 19:01:22 +0200
commitfb574eead5eb9b7a37bbf41bc2d27010bb83b76f (patch)
tree6f7dc243c79c5fce3cb62f855e8eaf4bdc947c2e
parentcb7e68f2a39fa6f24add48fc7b8d38fb7291bb44 (diff)
downloadmeta-openembedded-contrib-fb574eead5eb9b7a37bbf41bc2d27010bb83b76f.tar.gz
python-cryptography: fix build issue do to openssl 1.0.1g upgrade
this fixes build/temp.linux-x86_64-2.7/_openssl.c:697:6: error: conflicting types for 'BIO_new_mem_buf' BIO *BIO_new_mem_buf(void *, int); ^ In file included from /home/jenkins/oe/world/shr-core/tmp-glibc/sysroots/qemuarm/usr/include/openssl/asn1.h:65:0, from build/temp.linux-x86_64-2.7/_openssl.c:413: Signed-off-by: Armin Kuster <akuster@mvista.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python-cryptography/build_fix_openssl_1.0.1g.patch28
-rw-r--r--meta-python/recipes-devtools/python/python-cryptography_0.8.1.bb1
2 files changed, 29 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-cryptography/build_fix_openssl_1.0.1g.patch b/meta-python/recipes-devtools/python/python-cryptography/build_fix_openssl_1.0.1g.patch
new file mode 100644
index 0000000000..cbdc8ceaf2
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-cryptography/build_fix_openssl_1.0.1g.patch
@@ -0,0 +1,28 @@
+build issue do to openssl 1.0.1g upgrade
+
+BIO *BIO_new_mem_buf(void *, int);
+ ^
+In file included from /home/jenkins/oe/world/shr-core/tmp-glibc/sysroots/qemuarm/usr/include/openssl/asn1.h:65:0,
+from build/temp.linux-x86_64-2.7/_openssl.c:413:
+
+
+Upstream-Status: Pending
+
+seems to be a known issue
+https://github.com/pyca/cryptography/issues/2750
+
+Signed-off-by: Armin Kuster <akuster@mvista.com>
+
+Index: cryptography-0.8.1/src/cryptography/hazmat/bindings/openssl/bio.py
+===================================================================
+--- cryptography-0.8.1.orig/src/cryptography/hazmat/bindings/openssl/bio.py
++++ cryptography-0.8.1/src/cryptography/hazmat/bindings/openssl/bio.py
+@@ -99,7 +99,7 @@ BIO *BIO_pop(BIO *);
+ BIO *BIO_next(BIO *);
+ BIO *BIO_find_type(BIO *, int);
+ BIO_METHOD *BIO_s_mem(void);
+-BIO *BIO_new_mem_buf(void *, int);
++BIO *BIO_new_mem_buf(const void *, int);
+ BIO_METHOD *BIO_s_file(void);
+ BIO *BIO_new_file(const char *, const char *);
+ BIO *BIO_new_fp(FILE *, int);
diff --git a/meta-python/recipes-devtools/python/python-cryptography_0.8.1.bb b/meta-python/recipes-devtools/python/python-cryptography_0.8.1.bb
index 41e4acdb5b..cd1011823a 100644
--- a/meta-python/recipes-devtools/python/python-cryptography_0.8.1.bb
+++ b/meta-python/recipes-devtools/python/python-cryptography_0.8.1.bb
@@ -7,6 +7,7 @@ SRCNAME = "cryptography"
SRC_URI = "https://pypi.python.org/packages/source/c/${SRCNAME}/${SRCNAME}-${PV}.tar.gz \
file://run-ptest \
+ file://build_fix_openssl_1.0.1g.patch \
"
S = "${WORKDIR}/${SRCNAME}-${PV}"