summaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorPhil Blundell <pb@pbcl.net>2012-09-08 22:49:07 +0100
committerPhil Blundell <pb@pbcl.net>2012-09-08 22:49:07 +0100
commit431cfa374d4715970fb3f1614021d7553bf8fea0 (patch)
tree8ce23bf2709528d1dd39d72530661352a51da0a7 /recipes
parentcfde70ed14874a26deff79e21a84c2a3a79bfc5e (diff)
downloadmeta-micro-431cfa374d4715970fb3f1614021d7553bf8fea0.tar.gz
eglibc: fix sundry packaging issues
oe-core commit 13544fbc6217fee1731a6da1e2cf94901a500842 changed the order of PACKAGES, which causes some files to land in the wrong place. Put it back. Also remove some unshipped files that were causing warnings, and patch up do_install to respect ${sbindir}.
Diffstat (limited to 'recipes')
-rw-r--r--recipes/eglibc/eglibc_2.16.bbappend16
1 files changed, 15 insertions, 1 deletions
diff --git a/recipes/eglibc/eglibc_2.16.bbappend b/recipes/eglibc/eglibc_2.16.bbappend
index 586bfa3..fa8b811 100644
--- a/recipes/eglibc/eglibc_2.16.bbappend
+++ b/recipes/eglibc/eglibc_2.16.bbappend
@@ -1,6 +1,20 @@
-PR .= ".micro1"
+PR .= ".micro2"
THISDIR := "${@os.path.dirname(bb.data.getVar('FILE', d, True))}"
FILESPATH =. "${@base_set_filespath(["${THISDIR}/${PN}-${PV}", "${THISDIR}/files"], d)}:"
SRC_URI += "file://ldso-no-hwcaps.patch"
+
+PACKAGES = "${PN}-dbg catchsegv sln nscd ldd ${PN}-mtrace ${PN}-utils eglibc-thread-db ${PN}-pic libcidn libmemusage libsegfault ${PN}-pcprofile libsotruss ${PN} eglibc-extra-nss ${PN}-dev ${PN}-staticdev ${PN}-doc"
+
+FILES_sln = "${sbindir}/sln"
+
+do_install_append() {
+ if [ "${sbindir}" != "/sbin" ]; then
+ mv ${D}/sbin/sln ${D}${sbindir}/
+ fi
+ rm ${D}${sysconfdir}/ld.so.conf
+ rm ${D}/sbin/ldconfig
+ rmdir ${D}${sysconfdir} || true
+ rmdir ${D}/sbin || true
+}