aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrea Adami <andrea.adami@gmail.com>2017-02-24 00:57:12 +0100
committerAndrea Adami <andrea.adami@gmail.com>2017-02-24 01:14:42 +0100
commit3e6e5d2ed4c6c72fdf9d738445735ce4183812fb (patch)
tree4db18b17924730fd32c754809c8d1d0e307c7ae0
parentd4bcbd1110f1af3804bea70100c213fd47190eb7 (diff)
downloadmeta-handheld-3e6e5d2ed4c6c72fdf9d738445735ce4183812fb.tar.gz
zaurus-utils: fix deploy task and rebuild from sstate
After the changes in oe-core (6d969bac) the recipes inherit staging.bbclass have to stage in DEPLOYDIR and not in DEPLOY_DIR_IMAGE otherwise sstate can not work. Signed-off-by: Andrea Adami <andrea.adami@gmail.com>
-rw-r--r--recipes-bsp/zaurus-utils/zaurus-installer.bb14
-rw-r--r--recipes-bsp/zaurus-utils/zaurus-legacy-tar.bb4
-rw-r--r--recipes-bsp/zaurus-utils/zaurus-updater.bb4
3 files changed, 11 insertions, 11 deletions
diff --git a/recipes-bsp/zaurus-utils/zaurus-installer.bb b/recipes-bsp/zaurus-utils/zaurus-installer.bb
index 0d7d439..5351ada 100644
--- a/recipes-bsp/zaurus-utils/zaurus-installer.bb
+++ b/recipes-bsp/zaurus-utils/zaurus-installer.bb
@@ -21,17 +21,17 @@ inherit deploy
addtask deploy before do_populate_sysroot after do_compile
do_deploy() {
- cd ${DEPLOY_DIR_IMAGE}
- rm -rf ${DEPLOY_DIR_IMAGE}/installkit-${MACHINE}/
+ cd ${DEPLOYDIR}
+ rm -rf ${DEPLOYDIR}/installkit-${MACHINE}/
mkdir installkit-${MACHINE}/
- [ -f "${KERNEL_IMAGETYPE}-kexecboot-${MACHINE}.bin" ] && cp ${KERNEL_IMAGETYPE}-kexecboot-${MACHINE}.bin installkit-${MACHINE}/${KERNEL_IMAGETYPE}
+ [ -f "${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGETYPE}-kexecboot-${MACHINE}.bin" ] && cp ${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGETYPE}-kexecboot-${MACHINE}.bin installkit-${MACHINE}/${KERNEL_IMAGETYPE}
if [ ! "${MACHINE}" = "collie" ]; then
- cp updater.sh installkit-${MACHINE}/updater.sh
+ cp ${DEPLOY_DIR_IMAGE}/updater.sh installkit-${MACHINE}/updater.sh
fi
if [ "${MACHINE}" = "spitz" ]; then
cp ${DEPLOY_DIR_IMAGE}/gnu-tar installkit-${MACHINE}/gnu-tar
fi
- tar czf ${DEPLOY_DIR_IMAGE}/installkit-${MACHINE}.tar.gz installkit-${MACHINE}/
- md5sum ${DEPLOY_DIR_IMAGE}/installkit-${MACHINE}.tar.gz > ${DEPLOY_DIR_IMAGE}/installkit-${MACHINE}.tar.gz.md5
- rm -rf ${DEPLOY_DIR_IMAGE}/installkit-${MACHINE}/
+ tar czf ${DEPLOYDIR}/installkit-${MACHINE}.tar.gz installkit-${MACHINE}/
+ md5sum ${DEPLOYDIR}/installkit-${MACHINE}.tar.gz > ${DEPLOYDIR}/installkit-${MACHINE}.tar.gz.md5
+ rm -rf ${DEPLOYDIR}/installkit-${MACHINE}/
}
diff --git a/recipes-bsp/zaurus-utils/zaurus-legacy-tar.bb b/recipes-bsp/zaurus-utils/zaurus-legacy-tar.bb
index a145f8f..01b203d 100644
--- a/recipes-bsp/zaurus-utils/zaurus-legacy-tar.bb
+++ b/recipes-bsp/zaurus-utils/zaurus-legacy-tar.bb
@@ -21,6 +21,6 @@ do_configure[noexec] = "1"
do_compile[noexec] = "1"
do_deploy() {
- install -d ${DEPLOY_DIR_IMAGE}
- install -m 0755 ${WORKDIR}/zaurus-legacy-tar ${DEPLOY_DIR_IMAGE}/gnu-tar
+ install -d ${DEPLOYDIR}
+ install -m 0755 ${WORKDIR}/zaurus-legacy-tar ${DEPLOYDIR}/gnu-tar
}
diff --git a/recipes-bsp/zaurus-utils/zaurus-updater.bb b/recipes-bsp/zaurus-utils/zaurus-updater.bb
index 93fabeb..f191dc4 100644
--- a/recipes-bsp/zaurus-utils/zaurus-updater.bb
+++ b/recipes-bsp/zaurus-utils/zaurus-updater.bb
@@ -29,6 +29,6 @@ inherit deploy
addtask deploy before do_populate_sysroot after do_compile
do_deploy() {
- install -d ${DEPLOY_DIR_IMAGE}
- install -m 0755 updater.sh ${DEPLOY_DIR_IMAGE}/updater.sh
+ install -d ${DEPLOYDIR}
+ install -m 0755 updater.sh ${DEPLOYDIR}/updater.sh
}