aboutsummaryrefslogtreecommitdiffstats
path: root/doc
diff options
context:
space:
mode:
Diffstat (limited to 'doc')
-rw-r--r--doc/Makefile16
1 files changed, 15 insertions, 1 deletions
diff --git a/doc/Makefile b/doc/Makefile
index 29774e41c..6b2af6732 100644
--- a/doc/Makefile
+++ b/doc/Makefile
@@ -22,7 +22,7 @@
# make pdf DOC=user-manual
#
# The first example generates the HTML and PDF versions of the User Manual.
-# The second example generates the HTML version only of the User Manual.
+# The second example generates the HTML version only of the User Manual.
#
ifeq ($(DOC),user-manual)
@@ -73,5 +73,19 @@ tarball: html
validate:
cd $(DOC); xmllint --postvalid --xinclude --noout $(DOC).xml; cd ..
+publish:
+ @if test -f $(DOC)/$(DOC).html; \
+ then \
+ echo " "; \
+ echo "******** Publishing "$(DOC)".html"; \
+ echo " "; \
+ scp -r $(MANUALS) $(STYLESHEET) docs.yp:/var/www/www.yoctoproject.org-docs/$(VER)/$(DOC); \
+ cd $(DOC); scp -r $(FIGURES) docs.yp:/var/www/www.yoctoproject.org-docs/$(VER)/$(DOC); \
+ else \
+ echo " "; \
+ echo $(DOC)".html missing. Generate the file first then try again."; \
+ echo " "; \
+ fi
+
clean:
rm -rf $(MANUALS); rm $(DOC)/$(DOC).tgz;