aboutsummaryrefslogtreecommitdiffstats
path: root/bin
diff options
context:
space:
mode:
Diffstat (limited to 'bin')
-rwxr-xr-xbin/bitbake5
1 files changed, 5 insertions, 0 deletions
diff --git a/bin/bitbake b/bin/bitbake
index 324ee4fa5..e86d59bd6 100755
--- a/bin/bitbake
+++ b/bin/bitbake
@@ -214,6 +214,11 @@ Default BBFILES are the .bb files in the current directory.""")
if configuration.bind and configuration.servertype != "xmlrpc":
sys.exit("FATAL: If '-B' or '--bind' is defined, we must set the servertype as 'xmlrpc'.\n")
+ if "BBDEBUG" in os.environ:
+ level = int(os.environ["BBDEBUG"])
+ if level > configuration.debug:
+ configuration.debug = level
+
bb.msg.init_msgconfig(configuration.verbose, configuration.debug,
configuration.debug_domains)